TasmoAdmin

  • Scheint so, als hätten die Tasmota Entwickler etwas in der JSON Ausgabe geändert, was Tasmo-Admin nicht versteht.

    Scheint aber offensichtlich was Shelly-Spezifisches zu sein.


    Ich wüsste nicht, das es da neuerdings Änderungen gab, kann aber auch an mir vorbei gegangen sein.


    Tasmo-Admin erwartet den JSON String in einer ganz bestimmten Formatierung. Wenn der anders kommt, kommt Tasmo-Admin damit nicht klar.


    Da ist nix zu machen, es sei denn nils91 fix das.

    Es scheint um Tasmo-Admin aber Recht ruhig geworden zu sein.


    Falls Nils noch mitliest, kannst du mal den den Status 0 von der Konsole posten?

    Am besten von einem Gerät was noch funktioniert und von einem wo es nicht mehr geht.

  • ich habe die 1.6.5 im Docker auf einer Synology ohne Probleme laufen

    1. Hast du Shellys 2.5 mit Tasmota und Shutter in Betrieb ?

    2. Haste du TasmoAdmin auf 1.65 Docker upgedatet oder neu Installiert ?, wenn update wie ?

    grüsse aus Heidelberg


    2x Touch, 6x S20, 24x Basic (davon 8x 4.Relais am GPIO), 2x 4ch Pro, 1x 4ch, 2x TH16, 2x 7-32V Sonoff, 4x POW, 6x DUAL, 20x IR+Bridge.,3 RF-Bridhge.2xZigbee-Bridhe mit 5 Geräte, ,2x Obi Steckdose,4x Shelly 2.5, 6x Shelly 1, diverse Wemos und ESP01, Wemos mit SML Script.

    Domoticz, HA-Bridge,, 3xAlexa, MQTT, Pilot APP zur Steuerung , 2xFeinstaunsensor via Domoticz

  • Shelly 2 Shelly 1 Mini diverse verschiedene Sonoffs etc.

    also keine shelly 2,5 mit shutter.

    Alles andere funktioniert bei mir ja auch.



    Update:

    gleicher Anzeigefehler bei TasmoAdmin 1.6.5

    grüsse aus Heidelberg


    2x Touch, 6x S20, 24x Basic (davon 8x 4.Relais am GPIO), 2x 4ch Pro, 1x 4ch, 2x TH16, 2x 7-32V Sonoff, 4x POW, 6x DUAL, 20x IR+Bridge.,3 RF-Bridhge.2xZigbee-Bridhe mit 5 Geräte, ,2x Obi Steckdose,4x Shelly 2.5, 6x Shelly 1, diverse Wemos und ESP01, Wemos mit SML Script.

    Domoticz, HA-Bridge,, 3xAlexa, MQTT, Pilot APP zur Steuerung , 2xFeinstaunsensor via Domoticz

    Einmal editiert, zuletzt von mafrei ()

  • da kann ich leider nichts erkennen

    16:18:19 CMD: status 0

    16:18:19 MQT: stat/tasmota/STATUS = {"Status":{"Module":0,"DeviceName":"Terrasse","FriendlyName":["Terrasse rauf","Terrasse runter"],"Topic":"tasmota","ButtonTopic":"0","Power":0,"PowerOnState":3,"LedState":1,"LedMask":"FFFF","SaveData":1,"SaveState":1,"SwitchTopic":"0","SwitchMode":[0,0,0,0,0,0,0,0],"ButtonRetain":0,"SwitchRetain":0,"SensorRetain":0,"PowerRetain":0}}

    16:18:19 MQT: stat/tasmota/STATUS1 = {"StatusPRM":{"Baudrate":115200,"SerialConfig":"8N1","GroupTopic":"tasmotas","OtaUrl":"http://192.168.178.xxx:9999/data/firmwares/tasmota.bin","RestartReason":"Software/System restart","Uptime":"1T07:08:32","StartupUTC":"2020-09-09T08:09:47","Sleep":50,"CfgHolder":4617,"BootCount":28,"BCResetTime":"2020-04-04T08:15:18","SaveCount":1696,"SaveAddress":"F5000"}}

    16:18:19 MQT: stat/tasmota/STATUS2 = {"StatusFWR":{"Version":"8.5.0(tasmota)","BuildDateTime":"2020.09.07 10:54:46","Boot":31,"Core":"2_7_4_1","SDK":"2.2.2-dev(38a443e)","CpuFrequency":80,"Hardware":"ESP8266EX","CR":"419/699"}}

    16:18:19 MQT: stat/tasmota/STATUS3 = {"StatusLOG":{"SerialLog":2,"WebLog":2,"MqttLog":0,"SysLog":0,"LogHost":"","LogPort":514,"SSId":["xxxx","xxxx"],"TelePeriod":300,"Resolution":"55C180C0","SetOption":["0000C009","2805C8000100060000005A00000000000000","400000C0","00006000","00000000"]}}

    16:18:19 MQT: stat/tasmota/STATUS4 = {"StatusMEM":{"ProgramSize":596,"Free":404,"Heap":23,"ProgramFlashSize":1024,"FlashSize":2048,"FlashChipId":"1540EF","FlashFrequency":40,"FlashMode":3,"Features":["00000407","8FDAE797","04368001","000000CD","010013C0","C000F981","00004004","00000000"],"Drivers":"1,2,3,4,5,6,7,8,9,10,12,16,18,19,20,21,22,24,26,27,29,30,35,37","Sensors":"1,2,3,4,5,6"}}

    16:18:19 MQT: stat/tasmota/STATUS5 = {"StatusNET":{"Hostname":"tasmota-4355","IPAddress":"192.168.178.xxx","Gateway":"192.168.178.1","Subnetmask":"255.255.255.0","DNSServer":"192.168.178.1","Mac":"A4:CF:12:BA:71:03","Webserver":2,"WifiConfig":4,"WifiPower":17.0}}

    16:18:19 MQT: stat/tasmota/STATUS6 = {"StatusMQT":{"MqttHost":"192.168.178.xxx","MqttPort":1883,"MqttClientMask":"DVES_%06X","MqttClient":"DVES_BA7103","MqttUser":"xxx","MqttCount":1,"MAX_PACKET_SIZE":1200,"KEEPALIVE":30}}

    16:18:19 MQT: stat/tasmota/STATUS7 = {"StatusTIM":{"UTC":"2020-09-10T15:18:19","Local":"2020-09-10T16:18:19","StartDST":"2020-03-29T02:00:00","EndDST":"2020-10-25T03:00:00","Timezone":"+01:00","Sunrise":"05:54","Sunset":"18:47"}}

    16:18:19 MQT: stat/tasmota/STATUS9 = {"StatusPTH":{"PowerDelta":[0,0,0],"PowerLow":0,"PowerHigh":0,"VoltageLow":0,"VoltageHigh":0,"CurrentLow":0,"CurrentHigh":0}}

    16:18:19 MQT: stat/tasmota/STATUS10 = {"StatusSNS":{"Time":"2020-09-10T16:18:19","Switch1":"OFF","Switch2":"OFF","ANALOG":{"Temperature":64.6},"ENERGY":{"TotalStartTime":"2020-01-13T17:08:40","Total":0.320,"Yesterday":0.001,"Today":0.001,"Power":[0,0],"ApparentPower":[0,0],"ReactivePower":[0,0],"Factor":[0.00,0.00],"Frequency":0,"Voltage":0,"Current":[0.000,0.000]},"Shutter1":{"Position":100,"Direction":0,"Target":100},"TempUnit":"C"}}

    16:18:19 MQT: stat/tasmota/STATUS11 = {"StatusSTS":{"Time":"2020-09-10T16:18:19","Uptime":"1T07:08:32","UptimeSec":112112,"Heap":23,"SleepMode":"Dynamic","Sleep":50,"LoadAvg":19,"MqttCount":1,"POWER1":"OFF","POWER2":"OFF","Wifi":{"AP":1,"SSId":"xxxxx","BSSId":"B4:FB:E4:F7:31:D0","Channel":6,"RSSI":92,"Signal":-54,"LinkCount":1,"Downtime":"0T00:00:09"}}}

    16:18:19 MQT: stat/tasmota/STATUS13 = {"StatusSHT":{"SHT0":{"Relay1":1,"Relay2":2,"Open":180,"Close":160,"50perc":50,"Delay":0,"Opt":"0000","Calib":"300:500:700:900:1000"}}

    grüsse aus Heidelberg


    2x Touch, 6x S20, 24x Basic (davon 8x 4.Relais am GPIO), 2x 4ch Pro, 1x 4ch, 2x TH16, 2x 7-32V Sonoff, 4x POW, 6x DUAL, 20x IR+Bridge.,3 RF-Bridhge.2xZigbee-Bridhe mit 5 Geräte, ,2x Obi Steckdose,4x Shelly 2.5, 6x Shelly 1, diverse Wemos und ESP01, Wemos mit SML Script.

    Domoticz, HA-Bridge,, 3xAlexa, MQTT, Pilot APP zur Steuerung , 2xFeinstaunsensor via Domoticz

    2 Mal editiert, zuletzt von mafrei ()

  • Hast du nochmal einen von einer 8.4er Version wo's noch ging?


    Ich bin grade nur mitm Handy on. Ich guck mir das heut Abend mal an.

    leider Nein, ich habe mit TasmoAdmin alle automatisch geflasht. Lief alles durch, die 4 Shelly wurden auch geflasht nur die Anzeige in TA sehe ich nicht mehrt. Sie funktionieren aber.


    Json Fehler in Post #560 zu sehen.

    grüsse aus Heidelberg


    2x Touch, 6x S20, 24x Basic (davon 8x 4.Relais am GPIO), 2x 4ch Pro, 1x 4ch, 2x TH16, 2x 7-32V Sonoff, 4x POW, 6x DUAL, 20x IR+Bridge.,3 RF-Bridhge.2xZigbee-Bridhe mit 5 Geräte, ,2x Obi Steckdose,4x Shelly 2.5, 6x Shelly 1, diverse Wemos und ESP01, Wemos mit SML Script.

    Domoticz, HA-Bridge,, 3xAlexa, MQTT, Pilot APP zur Steuerung , 2xFeinstaunsensor via Domoticz

  • Edit: Hab grade gesehen, du hast auf Github ja schon nen Issue angelegt...

    Ich denke mal, wir warten darauf, das sich Nils meldet...

    Ja, wurde auch bestätigt Nils wird das iwann sehen und es fixen.

    grüsse aus Heidelberg


    2x Touch, 6x S20, 24x Basic (davon 8x 4.Relais am GPIO), 2x 4ch Pro, 1x 4ch, 2x TH16, 2x 7-32V Sonoff, 4x POW, 6x DUAL, 20x IR+Bridge.,3 RF-Bridhge.2xZigbee-Bridhe mit 5 Geräte, ,2x Obi Steckdose,4x Shelly 2.5, 6x Shelly 1, diverse Wemos und ESP01, Wemos mit SML Script.

    Domoticz, HA-Bridge,, 3xAlexa, MQTT, Pilot APP zur Steuerung , 2xFeinstaunsensor via Domoticz

  • Fehler ab Version 1.7.0beta durch Nils beseitigt.

    grüsse aus Heidelberg


    2x Touch, 6x S20, 24x Basic (davon 8x 4.Relais am GPIO), 2x 4ch Pro, 1x 4ch, 2x TH16, 2x 7-32V Sonoff, 4x POW, 6x DUAL, 20x IR+Bridge.,3 RF-Bridhge.2xZigbee-Bridhe mit 5 Geräte, ,2x Obi Steckdose,4x Shelly 2.5, 6x Shelly 1, diverse Wemos und ESP01, Wemos mit SML Script.

    Domoticz, HA-Bridge,, 3xAlexa, MQTT, Pilot APP zur Steuerung , 2xFeinstaunsensor via Domoticz

  • Hi Nils, falls du noch mitliest .


    Die Update Möglichkeit ist super vor allem wenn man viele Geräte am laufen hat, funktioniert auch super.

    Wäre es möglich eine Funktion einzubauen die die Konfiguration der einzelnen Geräte auf einen Rutsch sichert ?

    grüsse aus Heidelberg


    2x Touch, 6x S20, 24x Basic (davon 8x 4.Relais am GPIO), 2x 4ch Pro, 1x 4ch, 2x TH16, 2x 7-32V Sonoff, 4x POW, 6x DUAL, 20x IR+Bridge.,3 RF-Bridhge.2xZigbee-Bridhe mit 5 Geräte, ,2x Obi Steckdose,4x Shelly 2.5, 6x Shelly 1, diverse Wemos und ESP01, Wemos mit SML Script.

    Domoticz, HA-Bridge,, 3xAlexa, MQTT, Pilot APP zur Steuerung , 2xFeinstaunsensor via Domoticz

  • Scheint wohl nicht mehr zu reagieren, aber dennoch seit Tasmota 9.x ist die Darstellung von Shelly 2,5 Geräten nicht mehr fehlerfrei. Bisher wurden immer beide Kanäle gelistet, leider ist das mittlerweile nicht mehr so, der zweite wird nicht mehr dargestellt. (TasmoAdmin 1.7.0)

    grüsse aus Heidelberg


    2x Touch, 6x S20, 24x Basic (davon 8x 4.Relais am GPIO), 2x 4ch Pro, 1x 4ch, 2x TH16, 2x 7-32V Sonoff, 4x POW, 6x DUAL, 20x IR+Bridge.,3 RF-Bridhge.2xZigbee-Bridhe mit 5 Geräte, ,2x Obi Steckdose,4x Shelly 2.5, 6x Shelly 1, diverse Wemos und ESP01, Wemos mit SML Script.

    Domoticz, HA-Bridge,, 3xAlexa, MQTT, Pilot APP zur Steuerung , 2xFeinstaunsensor via Domoticz

  • Hallo,

    es gibt ja das Problem , das die bin Dateien aufgrund der Größe sich nicht mal direkt per OTH flashen lassen.

    Die .gz Dateien also die gepackten gehen ohne Probleme.


    Leider kann TasmoAdmin keine .gz Dateien flashen, wäre schön, wenn das auch damit gehen würde.

    Muste gerade alle Geräte einzeln direkt per OTH flashen.


    cu Deta