Domoticz hat Kontakt zu Tasmotageräten verloren

  • Hallo,

    heute früh habe ich bemerkt, dass der Verbrauch der Sonoff-Pow nicht mehr aktualisiert wird. Ebenso kann ich vom Raspi aus nicht mehr das Licht schalten.

    Wenn ich aber die Geräte direkt über die Tasmotaoberfläche aufrufe, sehe ich die aktuellen Verbräuche und kann auch ein/aus schalten.

    Habe die Datenbank schon neu eingespielt, neu gestartet incl. Fritzbox. Hat sich nicht verbessert.

    Das System habe ich vor 2 Wochen neu aufgesetzt und alles funktionierte. Zwischenzeitlich aber noch fritzctl installiert.

    Würde mich über Lösungsansätze freuen.

    Danke

    Miranda

    Raspberry Pi mit Domoticz, angeschlossen mehrere Nodemcu mit Sensoren, Tasmota geflashte Sonoff Pow's und Sonoff S20

  • Hallo 4miranda, ich habe alle Deine Beiträge mal kurz überflogen.Du schreibst was von Mqtt. Ist das eingebunden in Domoticz?? bzw

    läuft das auf dem gleichen Rasp. Zu mir, ich bin nicht der Linux Freak. Der ein oder andere wird zwar hier schmuzeln, für mich aber wichtig das es läuft, und das seit meht als 4 Jahren. Angefangen mit Domoticz bei Version 1.XX . Bin gerade auch dabei meine Geräte auf Tasmota umzustellen was einfache Geräte betrifft, Hintergrund war die Unterstützung von DOMOTICZ. Es war aber ein langer Kampf am Anfang.Vieleicht hilft es Dir ein wenig, Anfänger bist Du Ja nicht wenn ich Deine Beiträge so lese.Ganz unten der Vorgang wie ich MQTT eingerichtet habe. Vielleicht hift es ja auch anderen was DOMOTICZ betrifft.

    Gruß

    Jürgen


    1. Also ich habe es unter Domoticz am laufen, beim einbinden eines Tasmotagerätes brauche ich nur folgendes zu tun.



    2.Gerät beschreiben, IDX merken


    3.Tasmotagerät öffnen und IDX eintragen und speichern. Ich bin kein Freund von vielen Rules in Domoticz.


    Das war es auch schon. Läuft bei mir seit Jahren ohne Probleme.


    Für komplexe Dinge arbeite ich nach wie vor mit ESPEASY wie im Beispiel hier.

    Habe mir das mal gemacht für die Heizung,hängt aber jetzt am Raspberry 1 Wire Bus

    IDX in ESPEASY. Also ich habe es bisher nicht geschaft in Tasmota diese 8 sensoren unter GENERIC einzubinden,

    , daher bin ich bei diesem Kompromiss geblieben. Ich denke ohne einen Eingriff in den Config Dateien zu machen

    unter VSC, ATOM und so weiter.


    Hier die Temperaturen einzig über den Index


    Hier das Protokoll vom Beispiel in Domoticz Flur/Bär


    Auszug MQTT


    Mit Hilfe von Putty wurde an Hand der nachfolgenden Anleitung MQTT so bei mir installiert.

    Alles aus diversen Foren so zusammen getragen


    2020-09-26-raspbian-buster-lite


    1. update the raspberry pi: Je nach IMAGE Alter nicht unbedingt nötig


    sudo apt-get update && sudo apt-get upgrade


    2. install mosquitto:


    sudo apt-get install mosquitto mosquitto-clients


    3. make a mqtt user:


    sudo mosquitto_passwd -c /etc/mosquitto/pwfile


    4. add a couple of rules to the config:


    sudo nano /etc/mosquitto/mosquitto.conf


    4. add these to mosquitto.conf:

    Copy und Paste the next betwen the Lines to Config

    ---------------------------------------------------------------------------


    pid_file /var/run/mosquitto.pid

    persistence true

    persistence_location /var/lib/mosquitto/

    log_dest syslog

    log_dest stdout

    log_dest topic

    log_type error

    log_type warning

    log_type notice

    log_type information

    connection_messages true

    log_timestamp true

    log_dest file /var/log/mosquitto.log

    allow_anonymous false

    password_file /etc/mosquitto/pwfile


    ----------------------------------------------

    5. save it with these key combinations:

    ctrl+O and ctrl+X


    6. open rc.local:


    sudo nano /etc/rc.local


    7. put in before exit 0 the next in following:


    /usr/sbin/mosquitto -d


    7. save with these key combinations:

    ctrl+O and ctrl+X



    8. restart your pi:


    sudo reboot


    9. open domoticz via the web interface


    10. go to: settings - hardware


    11. add new hardware:

    MQTT Client Gateway with Lan Interface

    ----------------------------------------------------------------------------------------------------

    name: MQTT

    type: MQTT Client Gateway with LAN interface

    remote address: the ip address of your pi

    Port: 1883

    Username: pi

    Password: xxxxx // your you make under 3

    Publish topic: out

    ----------------------------------------------------------------------------------------------------

    12.test your mqtt

    Befehl:

    mosquitto_sub -h 192.168.08.15 -v -t "#" // Eure Ip


    13.Mit CRTL+C verlassen

  • Hallo Jürgen,

    vielen Dank für deinen Beitrag und die Beispielbilder.

    meinen Fehler habe ichzwischenzeitlich bereinigen können. Weil ich LAN angeschlossen habe und der Raspi recht heiß wurde, hatte ich das WLAN un BT abgestellt, in der Hoffnung, dass die Last etwas verringert wird. MQTT hat sich aber beim Installieren die Wlan-Adresse gekrallt und wollte sich auch nach Neuinstallation nicht dazu bewegen, die Lan-Adresse zu verwenden. Was ich bis jetzt nicht verstehe. Neuinstallation nur mit Lan-Anschluß und dennoch die IP des "ehemaligen" Wlan.


    Meine DS18B20 hängen an Nodemcu's und da bin ich auch auf ESPeasy gegangen, war einfacher. So überwache ich z.B. meinen Kühlschrank, außen zusätzlich ein OLED und bei Temperaturüberschreitung Alarm über Telegram.


    Jetzt macht mir nur noch die Einordnung in Domoticz des Fritzbox kompatible Eurotronic 700018 Comet Dect Heizkörperthermostat zu schaffen.


    Könntest du mir aber noch mal schreiben, was das unter

    4. add these to mosquitto.conf:

    bewirkt?


    Danke

    4Miranda

    Raspberry Pi mit Domoticz, angeschlossen mehrere Nodemcu mit Sensoren, Tasmota geflashte Sonoff Pow's und Sonoff S20

  • Hallo 4miranda, wenn ich da eine Antwort wüsste.

    Ich habe das glaube ich aus dem Forum von Domoticz übernommen im Zusammenhang mit einem RFXTRX vom Nodoshop für meine

    Wetterstation und 433MHZ Funksteuerungen.

    So war es am Anfang, lief aber nicht problemlos

    4. add these to mosquitto.conf:

    Copy und Paste the next 2 Lines

    Minimal:

    allow_anonymous false

    password_file /etc/mosquitto/pwfile


    Dann wurde es so aus einem anderen Beitrag ergänzt


    #autosave_on_changes true

    persistence true

    persistence_location /var/lib/mosquitto/

    log_dest syslog

    log_dest stdout

    log_dest topic

    log_type error

    log_type warning

    log_type notice

    log_type information

    connection_messages true

    log_timestamp true

    allow_anonymous false

    password_file /etc/mosquitto/pwfile


    Fakt ist bei mir läufts so, daher NEVER TOUCHING RUNNING SSYSTEM

    Ich speichere mir die ganzen Befehle immer in einer txt Datei ab, da ich mich nach wie vor

    als LINUX Anfänger betrachte und das gar nicht mir alles merken kann.Habe auch um die Weihnachtszeit meine System neu aufgesetz.

    in 20 Minuten war das ganze elrledigt.Bei mir wird außerdem jede Nacht um 1Uhr

    automatisch die Domoticz.DB gepackt, und auf meine gute alte Buffalo NAS hochgeladen.

    Tut mir leid wenn ich Dir da nicht viel weiterhelfen kann, bzw. mehr dazu sagen kann

    Gruß

    Jürgen und weiterhin viel Erfolg

  • Juergen.E  4miranda

    Eine Erklärung zu mosquitto.conf findet sich hier: mosquitto.conf auf Github

    Unter 4) sind etliche Logs aktiviert, anonyme Anmeldung unterbunden und die Häufigkeit der Datenbankaktualisierung erhöht. Ob das alles wirklich wichtig ist, bezweifle ich ein wenig. Für das Debuggen sicherlich aber als Standardeinstellung...?