Shelly als Stromstossrelais - Licht geht aus und sofort wieder an? Defekt oder Fehler gemacht?

  • Hallo Zusammen,


    seit kurzem will ich auch sämtliche Schalter mit einem Shelly 1 bzw. auch 2. versehen. 5 Stück habe ich erfolgreich verbaut. Doch bei meinem Taster zum Kommodenlicht habe ich ein Problem, für das ich selbst keine Ursache finden kann.


    Zur Situation:

    Es geht um meinen Flur. Hier gibt es 2 Taster (und demzufolge 2 Stromstoßrelais im Sicherungskasten) für 2 Leuchten, einmal das Deckenlicht (Halogenspots mit Trafo) und einmal ein Licht an der Kommode (4 dimmbare E14 Led-Lampen). Ich habe beide Relais ersetzt.


    Die gleiche Dauerphase per WAGO auf L und I beider Relais

    Neutralleiter auf N

    Die Stromstoßphase der Schalter auf SW

    Die Verbraucher auf O


    Beide Shellys laufen mit der ausgelieferten original Firmware, welche auch bereits kurz nach der Installation geupdatet wurde und beide wurden auf "Momentary" gestellt.


    Zum Problem:

    Beide Shellys werden erkannt und können problemlos per Software geschaltet werden. Drücke ich beim Deckenlicht den Taster, schaltet sich das Licht ein, sobald ich den Taster loslasse. Selbiges beim Ausschalten. Auch das Kommodenlicht schaltet sich ein, sobald ich den Taster wieder loslasse. NUR drücke ich des Taster des Kommodenlichts erneut zum Ausschalten und lasse ich ihn los, schaltet sich das Licht für einen Bruchteil einer Sekunde auch aus, jedoch sofort wieder ein! Das ganze auch oft beim 2ten oder 3ten mal. Es sind oft ca. mehrere Versuche nötig um das Kommodenlicht per Taster tatsächlich wieder auszuschalten.


    Meine Problemsuche:

    Messe ich mit einem Multimeter den SW-Draht zum Shelly 1, kann ich ohne Probleme feststellen, dass beim Drücken des Tasters 230 V anliegen und beim loslassen diese wieder weg sind - > so wie es ja eigentlich auch sein sollte. Nur meine ich ab und an mal kleinere Spannungen <10V kurz gesehen zu haben. Berühre ich mit einem üblichen Phasenprüfer-Schraubenzieher die Schraube des SW-Eingangs des angeschlossenen Shellys, erkennt Shelly eine Schalterbetätigung und schaltet ein bzw. aus (bei beiden).


    Kann es also sein, dass irgendwelche Spannungsschwankungen die über SW-Kabel nach dem Betätigen "mitkommen" den Shelly im Bruchteil einer Sekunde "nochmal" Schalten lassen? Ich finde es seltsam, dass ich beim Deckenlicht keinerlei Probleme habe..


    Besten Gruß

  • Das Problem habe ich bei meinem Flurlicht mit Eltako-Schaltung auch gehabt, liegt wohl an

    Einstreuungen/Induktion von parallelen Leitungen.


    Ich habe bei mit die Eltakos drin gelassen und den Shelly1 einfach als weiteren Taster

    (AUTO-AUS nach 0,2s) eingestellt und das ganze funktioniert.

    Nachteil: in der App wird nicht die korrekte Rückmeldung der Leuchten angezeigt, da der

    Shelly ja immer nach 0,2s wieder aus zeigt, damit kann ich aber gut leben.

    Harry


    1xEcho Show, 1xEcho2, 3xEcho Dot, 1xEcho Connect; Broadlink RM Pro; Broadlink mini3;
    2xAVM FRITZ!BOX (7590/7490) DECT200/210-Steckdosen und DECT301-Heizkörperthermostat

    Shelly 1, 2, 2.5 und H/T

  • Danke für den Hinweis! Fast vermutet..


    Der Shelly ist auch da auch anscheinend sehr empfindlich. Es müsste eine Funktion geben, dass man weitere Schaltimpulse um XXX Sek nach dem ersten ignorieren kann.


    Hmm… deine Lösung habe ich bereits an meinem Garagentor-Antrieb eingebaut, da hier kein das Stromstoßrelais direkt im Garagenmotor ist. Hier stört es mich allerdings gewaltig nicht den korrekten Öffnungszustand des Tors auf dem Handy sehen zu können. Trotzdem ist es ja nur so möglich.


    Ich werde überlegen ob ich es so umbaue. Es passiert ja letztlich nur bei dem Kommodenlicht, was ich ja eh meist per Alexa anmache von ganz wo anders.


    Schönes WE!

  • Habe das Problem bei 3 eltakos, die ich gerne ersetzen würde. Ich brauche allerdings immer den aktuellen Status an/aus.

    Gibt es mittlerweile softwareseitige Updates? Könnte man das evtl. mit Tasmota lösen?