Beiträge von nils91

    Huhu,


    ich komme auch nicht mehr hinterher, zuviele Änderungen in zu kurzer Zeit und es gibt auch keine Testphase sondern geht ohne Rücksicht auf Verluste ins Release.


    Stabil läuft es bei mir auch nicht im Moment, die Version davor lief besser. Jetzt wieder tägliche Exceptions/Restarts...


    Alle zur geichen Zeit geflasht und danach gleichzeitig neugestartet zum Vergleichen.


    Solange ich da keine Testwerte vom Stomverbrauch gesehen habe, bleibe ich bei 2.3.0.


    Ich glaube da haben die Chinesen nämlich geschummelt.

    Nach 2.3.0 ging der LIGHT_SLEEP der stromsparend war nicht mehr, ab 2.5.0 geht zwar sleep wieder, aber soweit ich gesehen habe wird nun nur noch MODEM_SLEEP benutzt. Dies macht zu einem bei mir Probleme im WLAN (Gerät xyz reagiert nicht) und zum anderen soll der Stromverbrauch höher sein.


    Die sleep funktion liegt unter dem "Core". Core ist hier die falsche Bezeichnung im Thread.

    Tasmota -> Arduino ESP Library -> Core

    Und den Core machen die Chinesen, die ESP Lib die Community.

    2.5.0 (oder 2.4.2) ist die Arduino ESP Library.


    Da ich meine Rechnung selbst bezahlen muss bleibe ich bei 2.3.0 bis ich einen Vergleich habe.


    Bei mehreren Tasmota Geräten sollte man den Stromverbrauch nicht unterschätzen 24/7/365.



    Ansonsten Danke für den Hinweis, ich habe es auch mal im Tasmota Discord gepostet, vlt war es unabsichtlich.

    VIelen Dank, so ein Statement ist Top und beruhigt die Gemüter :thumbup:


    An die immer noch ungeduldigen Käufer: auch andere Verkäufer haben Lieferprobleme, dass weitet sich auf alle aus wenn der Hersteller nicht hinterher kommt. Stornieren und woanders neubestellen wirft euch also unter Umständen nur weiter nach hinten in der Warteliste.

    Ohne den Markt jetzt genau zu kennen, würde ich sagen dass CreationX schon ein größerer/wichtiger Kunde beim Hersteller ist und auch dass beachtet der Hersteller wer die frisch produzierte Ware zuerst bekommt.


    Bleibt letzendlich natürlich jedem selbstüberlassen.



    Frohes Fest,guten Rutsch und bleibt geduldig! :saint:

    also ich würd sagen so funktioniert dein if/else nicht.


    du darfst nicht sensor1 oder sensor2 = wahr machen.


    du musst daraus sensor1 = wahr oder sensor2 = wahr basteln


    Logik dahinter:

    jede seite vom "oder" ist eine bedingung, in deinem fall wäre das übersetzt

    wenn sensor1 gesetzt ist oder sensor2 gleich wahr ist.


    es sollte aber sein

    wenn sensor1 gleich wahr ist oder sensor2 gleich wahr ist.



    hoffe du verstehst was ich meine ^^


    wenn du auf den knopf zum generierten javascript anzeigen klickst, siehst du auch was ich meine.

    da sollte dann auch

    Code
    1. if(sensor1 || sensor2 == true)...

    stehen.

    richtig wäre

    Code
    1. if(sensor1 == true || sensor2 == true)...


    da hast du ein allgemeines verständnis problem vom if()

    Wollte gerade ein aktuelles Rasbian Image runterladen und hab folgendes gefunden:

    Code
    1. 2018-11-13: * Two versions of image created - "base" image has no optional software packages included; "full" image has all optional packages - Removed from "base" image - LibreOffice, Thonny, Scratch, Scratch 2, Sonic Pi, Minecraft, Python Games, SmartSim, SenseHAT Emulator - Added to "full" image - Mathematica, BlueJ, Greenfoot, Node-RED, Claws Mail, VNC Viewer

    Es gibt also jetzt auch eine Rasbian Version ohne den ganzen Mist ^^


    https://www.raspberrypi.org/downloads/raspbian/

    Ich habe 2 Shelly1 bei mir mit Tasmota verbaut und die lassen sich problemlos in TasmoAdmin darstellen und schalten.


    Was bei mir ums verrecken nicht funktionieren will sind die Anzeige der Sensoren. Verbaut habe ich am Sonoff RF einen DHT11 und wird auch in der Tasmota Weboberfläche angezeigt, nur eben nicht in TasmoAdmin. Installiert ist das ganze auf einem Raspberry Pi3 mit aktuellem Raspian Stretch. Hat da jemand eine Idee?


    LG Mario

    jap lass mir bitte einmal einen status 0 response von dem teil zukommen.


    http://DEINESONOFFRFIP/cm?cmnd=status%200
    (wenn du firefox benutzt die rohdaten)

    Huhu,


    heute gabs ein commit im Tasmota Github der für den ein oder anderen Shelly 2 Besitzer intressant sein dürfte:

    Fix shelly2 ghost switching caused by lack of pull-up inputs (#4255)


    Issue: https://github.com/arendst/Sonoff-Tasmota/issues/4255

    Commit: https://github.com/arendst/Son…bac23f5afb378b226fac9ceee


    Sollte eure Shelly 2 mit Tasmota also mal von alleine an/aus gehen, sollte dies mit der nächsten Version behoben sein.

    hue war in der arduino libb verbugt und musste manuel ge-workaround-ed werden.

    dies ist nun behoben mit über 2.4.2 (2.4.3 oder 2.5.0)


    sleep soll wieder gehen, aber solange ich keine messung vom stromverbrauch sehe, werde ich da misstrauisch sein. was geht ist, dass tasmota mit neuem core und sleep nicht mehr einfriert, ob wirklich strom gespart wird konnte aber bisher niemand bestätigen.


    dazu kommt, dass das neue sleep mega probleme bei mir macht (keine wifi verbindung mehr nach einiger kurzer zeit). komischerweise nur mit der software die ich selbst builde. lade ich die fertige bin runter klappt es.


    wenn ihr den neuen core benutzen wollt, AUFJEDENFALL VORHER an einem testgerät welches nicht iwo fest verbaut ist ein paar tage testen/laufen lassen und zwischendurch auch mal mit dem sleep wert spielen ( dh mal 0 mal 25 mal 150 usw testen ).


    bei mir sind die geräte nicht mehr erreichbar sobald ich von sleep 150 auf sleep 0 gesetzt habe.




    nebeibei gemerkt: der pullrequest zum hue fix war 8 monate offen in der arduino lib und hatte nur eine einzige zeile änderung von nöten. jetzt vor ca 2 wochen wurde es endlich angegangen und es war ein riesen akt. der zuständige dev von der arduino lib ist nicht so einfach... und zufrieden mit der lösung die der dev da jetzt gebastelt hat bin ich auch nicht wirklich, heult rum wegen den ganzen web standards und da ist so ein bullshit rausgekommen...