Beiträge von VU-RE

    Ich habe jetzt mein Sonoff Pow R2 mit Tasmota für die PV Anlage im Betrieb wenn ich den Sonoff von Strom trenne verliert diese die gespeicherten Werte, ich kann mich erinner das man das einstellen kann das er diese nicht verliert bzw löscht. Ich weiß nur nicht mehr wo ich das gelesen habe.

    VU-RE Der niedrigste Wert für die Teleperiod ist 10s. Geringer geht es nicht. Es ist ja auch nicht einmal gesagt, dass die Zählerwerte überhaupt sekündlich ausgelesen wird.

    Für einen einzelnen Wert kann man gerne das hier beschriebene ausprobieren: RE: D0 Zähler SML auslesen mit Tasmota

    Gerade probiert sind jetzt ca. jede sekunde. Habe nur kurz geschaut wie der Zeitabstand ist könnte soagr noch weniger sein passt dann zum testen. Ich muss nur noch mein pow r2 flashen bekomme irgenwie keine Verbindung.

    Ich hätte mal ne frage zu tasmota teleperiod. Es funktioniert jetzt alles super und die 10 Sekunden Übertragungsintervall für MQTT ist auf dauer perfekt, aber ich würde gerne für paar Tage diesen Wert auf eine Sekunde oder niedrieger stellen. Gibt es da irgenwelche Möglichkeiten oder ist es Hardwareseitig nicht möglich ?

    Weil hinter 9600 ein ; und kein ,

    Hi, nochmal eine Nachfrage:

    Ich würde auch gerne Tasmota direkt den Tages-/ Wochen-/ Monatsverbauch ausrechnen lassen. Ich habe mich durch eure Skripte gelsen aber steige nicht durch die Variablen. Verzeiht meine Unwissenheit. Gibt es da auch irgendwo mal was für Einsteiger, wie das aufgebaut sein muss? Bin aktuell etwas überfordert. Danke euch.

    Ja hier gibtes genug beispiele. Ich finde das auch verwirend mit so vielen Variablen.


    Hier ist meine Version leider Funktioniert diese bei mir nicht komplett und diese müsste noch etwas angepasst bei v2 und v3 das sind die variuablen die eingelesen werden .

    Ich habe ein ganz komisches Verhalten mit meinem Script die Variable die im script als letztes definiert wird gibt falsche werte aus wenn ich die werte in der Konsole per Hand auf 0 stelle wird es auch übernommen. Nur wenn ich ein neustart mache werden die werde wieder auf falsche werte gestellt und das passiert nur bei den Variablen die ganz unten stehen wenn ich diese nach oben kopiere werden andere Variablen falsch ausgegeben. Ich glaube es liegt an zu wenig speicher, wie könnte ich das prüfen ob es am speicher liegt?


    Jenachdem was ganz unten bei >D steht verschiebt sich der flasche Wert. Ahja und Tasmota ist auf einer blitzwolf shp2 installiert ist halt speicher mäßig sehr begrenzt.



    Das sind meine Variablen.

    Danke @sunburstc Ich bin mit meinem script schon fast zufrieden, nurich hätte gerne noch den Wert der aktuellen Woche und der letzten Woche in Tasmota stehen leider habe ich keinen ansatz wie ich das programieren soll.


    Hier mein aktuelle Version.


    Ich habe Folgendes Script bei mir.

    Nur wird bei mir bei Tagesverbrauch und Tageseinspeisung immer nur 0 angezeigt. Ist das Script veraltet oder habe ich was beim compilieren falsch gemacht?


    Edit Fehler gefunden hinter

    Code
    +1,3,s,0,9600,SML

    sind leer zeichen und das sorgt für den fehler

    So funktioniert das nicht mehr. xsns_95_sml.ino gibt es auch garnicht mehr.

    Schau mal hier vorbei: HowTo

    Ah danke mit der Anleitung habe ich bereits gearbeitet aber in einer älteren Version aus dem Jahr 2020. Diese ist etwas verständlicher erklärt.


    Hier ist doch noch die xsns_95_sml.ino drin, aber damit muss ich nicht arbeiten? Ich muss nur in Tasmota unter Einstellungen Script die passenden DInge eintragen und dann müsste es gehen Richtig?

    Pumo Roadrunner


    Hallo ich habe einen eBZ DD3 Stromzähler und wollte mit einem ESP8266 mit Tasmota auslesen. Ein Volkszähler habe ich bereits gekauft, nur ich komme nicht weiter habe das ganze Wocheende damit verbracht aber komme zu keinem Ergebnis.


    Ich verstehe nicht so recht was ich ändern muss in den Datein, wenn ich kompelieren will.


    Ich habe folgendes hier im Forum für meinen StromZähler gefunden aber das geht auch nicht. Da fehlt noch etwas nur ich weiß nicht genau was.

    Hier noch mal meine Änderungen an der xsns_95_sml.ino (nur die Stellen, die ich eingefügt habe).