Beiträge von Plauzentiger

    MQTT.fx sagt im Log:


    2019-12-16 23:49:50,375 INFO --- MqttFX ClientModel : attempt to add PublishTopic

    2019-12-16 23:49:50,376 INFO --- MqttFX ClientModel : sucessfully published message on to topic cmnd/test0815x/POWER (QoS 0, Retained: true)


    und beim Verbinden:


    2019-12-16 23:51:40,909 INFO --- BrokerConnectorController : onConnect

    2019-12-16 23:51:40,910 INFO --- ScriptsController : Clear console.

    2019-12-16 23:51:40,912 INFO --- MqttFX ClientModel : MqttClient with ID 003c12a41e664bb0922cbe6aadac4799 assigned.

    2019-12-16 23:51:40,920 INFO --- MqttFX ClientModel : session present: false


    Was hat das mit session present: false auf sich?

    Bei Symcon kommt es auch hier an, aber nicht in der Tasmota und nicht im MQTT.fx


    Also ich kann nur zum Nachdenken anregen... Ich gucke mal, was ich zu MQTT Sessions finde.


    Gute Nacht!

    Hi, ja Port ist geändert. Ich habe auch einen Shelly 2.5 im IP symcon dazu verwendet einen weiteren zu schalten. Bei Garagenlicht aus, schaltet auch der Geräteraum ab. Ist das überhaupt schlau. Jetzt würde ich evtl. lieber ne Rule machen, aber ohne Publish wird es wohl nichts.


    Ich habe jetzt 100 Seiten Fotobuch für die Schwiegermutter anne Backen. Wenn das fertig ist probiere ich mit der Firmware und dem MQTT Tool aus. Noch 30 Seiten, was man nicht alles macht..


    Wenn noch jemand ne heiße Idee hat...

    Ich finde im gesamten Netz nichts dazu.


    Viele Grüße


    Manuel

    Hi Jörg,

    nein bei keinem der Shelly klappt dieses publish.

    Sonst läuft die gesamte MQTT Sache wunderbar. Das habe ich jetzt festgestellt weil ich über eine Rule verschiedene Shelly ansteuen will. Es geht um einen Flur bei dem die Lampen parallel geschaltet sind. Dann habe ich drei parallel liegende Bewegubgsmelder, Schalter. Die sollen zu tastern werden, mit dem shelly als Sender, der dann den sonoffs und shelly in den Lampen die Befehle gibt. So kann ich die einzeln steuern und das auch mit nem Taster. Die lampen hab ich dann auf ner dauerphase. Zu kompliziert?


    Und jetzt hab ich mich soo gefreut, dass das alles geht und moepp...


    Warum es bei allen nicht geht... Das muss was systematisches sein. Firmwareupdate wäre doof. Da hier alles von unten verlegt ist, sind die dosen so eng. Ich muss immer mit den kaiserschrauben arbeiten damit der Schalter bleibt wo der ist.


    Der wichtige shelly liegt noch im testaufbau auf dem Schreibtisch.


    Also kann doch nicht sein...

    Hallo!

    Danke für die Tipps!


    Prüfe also, ob das Gerät, das nicht hören will, seinerseits MQTT-Statements herausgibt und wie die aussehen, wenn du händisch oder per Weboberfläche schaltest bzw. Statusabfragen machst.

    Aber echt, alles andere läuft perfekt. Ich kann auf Webseite schalten und es kommt am Broker an. Ich kann cmnd in der Konsole machen, läuft. MQTT geht raus. WebOberfläche von IP Symcon zeigt das instantan an. Ich schalte auf der IP Symcon WEbseite MQTT geht raus und der test0815x schaltet.

    Nur sobald ich publish mache, geht die Message nur an Broker und Ende.

    Und das geht von keinem der 6 Shellys oder Sonoffs Tasmota Konsolen publish cmnd/test0815x/power on ... nur der Broker logged das ... verstehe ich nicht. Sowas nervt mich! Wieso geht das bei mir nicht?


    Oder geht das nur aus Rules heraus, nein...


    Viele Grüße


    Manuel

    Hi!

    Versuche es mal mit toggle anstelle von 2 bzw. on für 1 und off. Mit 1,0 und 2 hat ein Sonoff Basic auch bei mir nicht zuverlässig geschaltet, aber mit den entsprechenden Worten.

    Nee. Tut auch nicht.

    Also in der Konsole von Shelly test0815x funktioniert cmnd/test0815x/POWER on wunderbar . Aber aus der Konsole des Senders mit "publish" nicht.

    Hier wird es ausgeführt, und im Protokoll vom MQTT Broker im Symcon erscheint es auch, aber der Shelly test0815x macht keinen Mugs in der Konsole.


    12.12.2019, 00:57:49 | MQTT:RX:PUBLISH | Topic: cmnd/test0815x/POWER, Payload: off


    Verstehe ich nicht! Warum macht der nur ein RX er sollte das doch weitergeben.

    Hat da jemand einen Tipp?


    Danke!

    Plauzentiger

    Hi, vielen Dank! Ich habe das probiert gestern.

    Das ist ja der Knaller, was da alles gehen könnte ...


    Es sollte doch auf Anhieb klappen, oder?


    Der MQTT Server läuft ja. Aber es tut sich schon nichts, wenn ich an Gerät1 in der Konsole publish cmnd/test0815/POWER1 2 reingebe.

    Gerät2 mit Topic test0815 bekommt nichts...


    Somit waren auch die Rule Versuche fruchtlos.


    Viele Grüße


    Plauzentiger

    Hallo!


    Kurze Frage: Ganz oben schreibt NoitaercX im Quelltext SwitchTopic1 0 ...


    Was ich nun machen wollte: Den Shelly mit Tastern (kurzer oder langer Druck) steuern und dann

    je nachdem wie gedrückt wird über MQTT verschiede Geräte ansteuern.

    Der Shelly der gesteuert wird muss im Prinzip nur MQTT senden. Der Ausgang geht ins Leere.


    Ich war total froh, dass der sowas unterscheiden kann. Aber ich verstehe diese Option nicht.

    Würde das was ich vorhabe klappen? Also Tastendruck differezieren und dann entsprechde MQTT Message senden?

    Wie ich die Beschreibung der Option verstehe, werden eingehende MQTT Befehle nicht ausgeführt.


    Falls ich richtig liege, habt ihr eine Beispiel Rule zum Zeigen.


    Es geht um einen Flur, in dem ich jetzt bei kurzem Tasten nur eine kleine Hängelleuchte schalten möchte und bei langem Tasten

    alle Deckenleuchten einschalten möchte. Die Lampen haben dann Dauerphase mit Sonoffs oder Shellys, je nachdem was reinpasst.


    Viele Grüße


    Manuel

    So, Leute:


    Also, wie blöd kann man sein!!!!


    Lösung des Problems:


    Kabel defekt - mehrere!

    Also, wie kann etwas so einfaches defekt sein!


    Neue dran, 2 Minuten fertig.

    Hätte ich wohl gar nicht machen müssen - den Flash,

    weil mit vernünftigen Kabeln auch der Reset geklappt hätte.


    Ich flipp aus!

    Hi!


    Und jetzt? Im Prinzip habe ich mit dem Shelly ja nichts angestellt. Ging ja nichts, weder Reset noch Flash?

    Wie ist der CREATIONX-Support da drauf? Auf meine erste Frage zu diesem Thema bekam ich gar keine Antwort.... *gmpf*.


    Ein Shelly hab ich aus Wut so grob aufgebrochen, dass ich Widerstand geschrottet habe.

    Den werde ich mal neu einbauen.

    Muss ich nun doch ein Oszilloskop anklemmen? Gibt ja so Freaks...


    Wie sehe ich, ob schrott oder nicht? Ist hier jemand so fit...


    Viele Grüße


    Manuel

    Genauso mache ich das. Mit Atom bekomme ich immer, und immer wieder die Meldung:


    warning: espcomm_sync failed

    error: espcomm_open failed

    error: espcomm_upload_mem failed


    Mit meinen Sonoff Basics gab es null Probleme.


    Wie gesagt: GPIO0 ist bei "Strom an" am GND.


    Ich muss die auch nur flashen, weil beide nicht mehr erreichbar waren, am Garagentor.

    Oder gibt's Bugs, die man kennen sollte?

    Grüße

    Manuel

    Hallo, evtl. schon etwas zu speziell:


    Ich habe div. Shelly bei CREATIONX gekauft. Irgendwann sind zwei ausgestiegen. Von der FritzBox erkannt aber kein Zugriff auf's Device.

    Rücksetzen mit 40s GPIO0 + GND klappt nicht. Kein AP danach. Flash mit Atom und FTDI Modul ist nicht möglich, komme vermutlich nicht in den UploadModus.

    Habt ihr noch ne Idee?