Beiträge von homeboy

    Hi,


    wir haben eine Somfy Markise - diese habe ich bevor ich auf OpenHab umgestiegen bin mit einem CUL steuern können. Leider funktioniert das nicht so richtig mit Openhab und überlege nun wie ich das dennoch umsetzen kann. Raus / Rein / Stop reicht.


    Die Fernbedienung hat 3 Tasten (Raus / Rein / Stop)


    Im WZ habe ich einen Taster (normaler Taste kein 2 geteilter mit rauf runter) wenn ich diesen drücke fährt sie raus , sollte sie fahren und ich ihn erneut drücke stoppt sie und wieder erneut fährt sie wieder rein.


    Nun wäre meine Überlegung ob für sowas nicht ein shelly 1 reicht den ich hinter den Taster bau ? Oder brauche ich was anderes.


    Die Funktion des Tasters und der Fernbedienung sollen bestehen bleiben. Eventuell kann mir einer einen Tipp geben.

    Habe das ja mit nem Shelly umgesetzt da es mit einem Sonoff trotz pullup etc nicht tat- das Ding lief jetzt ein paar Monate richtig gut nun setzt es des öfteren aus. Das sieht dann so aus das das Licht einfach an geht und nicht mehr aus per Schalter oder App. Wie wenn sich das Shelly aufhängt aber es ist per Web erreichbar und ich kann auch schalten aber es passiert halt nichts. Es ist Tasmoto drauf instaliert - wenn ich die kabel zieh und neufestklemm tuts wieder - entweder ich hab sowas wie nen arking problem oder das Ding hängt sich doch irgendwie warum auch immer ? Kennt jemand sowas ? Kann man das fixen bzw was wäre zu prüfen ? Meiner Meinung nach sind die Kabel alle fest und ich glaube nicht das es sowas wie ein längen Problem oder so geben kann? Es tut bei neu anklemmen dann auch wieder ein paar Tage und irgendwann geht dann das Licht nicht mehr aus ... wie gesagt weder per web noch per schalter. Rein Sicherung raus und warten und rein damit der Shelly neu bootet bringt es nicht- also würde ich fast ein Softwareproblem ausschließen - aber es wird ja auch nichts an den Leitungen gemacht...?!

    Dazwischenpacken im Sinne von Tastendruck nachbilden (ohne Rückmeldung),


    Ja jein ich will den orig Wandtaster weiterverwenden aber es auch mit OpenHab steuern können.


    Muss ja einen Shelly hinter den Wandtaster schnaller - das wäre die korrekte Frage :)

    Hab eine Markise mit ner Somfy Steuerung - früher bei FEHM hab ich die direkt über meinen CUL angesprochen- mit Openhab geht das irgendwie nicht mehr so einfach. Jetzt hab ich mir überlegt den shelly dafür herzunehmen. Im Haus gibt es einen Taster der 3 Zustände abdeckt


    Drücken wenn Markise drinnen fährt sie raus und erneut drücken stoppt sie und wieder erneut wieder zurück.


    Wie könnte ich da nen shelly dazwischen packen ? Und vorallem was für einen ? brauch ich da den 2er oder den 1er ?

    Also hab mit dem Shells nun alles verkabelt und eingestellt Switchmode1 4 und das einzige was passiert ist bei länger drücken des Tasters das die Lampe ganz kurz anspringt - im Shelly tasmota ändert sich kein Status! Per tasmota an aus geht auch nix :( ich verzweifle

    danke - dachte ich mir nun im nachhinein auch... wenn da so klappt dann ersetz ich die 2 anderen auch mit Shellys und dann ist ruhe im Karton ! :)


    Vielen Dank bis dahin für eure Geduld und Mühe !


    Ich werde Feedback geben ! Tolle Community hier !

    Ok - wollte alles zurückbauen und hab alles durchgemessen und ich glaube ich hatte einen doppelten Effekt (den ich mir nur so erklären kann) - mit Koppelrelais hat es nicht funktioniert wegen PullUp und beim umbau auf Chaots Idee - wohl ein defektes Eltako.


    Bevor ich nun ein neues Eltako bestelle - hab ich ein Shelly bestellt um der ganzen Sache den gar auszumachen :)


    Hier wäre mein Aufbau- Eltako wird ersetzt durch Shelly 1 : (passt das) ?


    Vielen Dank für die Unterstützung bis hierher !

    Also das bringt es auch nicht :


    Status :


    Sonoff kann per Handy Lampe an und aus schalten


    Taster machen nichts / bringen auch nicht das Relais zum klacker


    Wenn ich den Eltako direkt drücke schaltet er das Licht - kann aus und anschalten


    Nur wenn die Lampe entweder über Eltako oder Sonoff angeschalten wurde kann ich sie per Taster aus machen ( relaise klickt doppelt)


    Mehr können die Taster aktuell nicht !!

    Bin am verzweifeln - hab es nun genauso umgebaut (mit Eltako) wie im Bild von Post #31


    Funktionsbeschreibung :


    Sonoff On / Off gegeben

    Lichttaster - macht nix

    Sonoff On -> Lichttaster kann ausmachen (manchmal beim 2. oder 3. mal (mit einem doppeltem oder dreifachen schnellen Relais Klackern)


    Licht über Taster wieder an geht nicht



    Dacht ich mir ok dann Lötest den PullUp (4.7K) ein


    Danach ist die Funktionsbeschreibung - selbige wie oben... an was kann das denn liegen ? Irgendeine Leitung zum Eltako falsch / verkehrt gesteckt - Sonoff falsch Konfiguriert ? Oder schließt man hier Sonoff komplett aus?


    Sonoff Einstellung ist - GPIO14 -> 09 Switch


    Konsole


    Code
    Savedata 1 / SwitchMode1 0 / Savedata 0

    Alles klar dann hab ich alles Verstanden !


    Warum gefährlich :) meine Zeichnung sagt ja klar und "deutlich" 1 und 2 von Eltako weg und zum sonoff IN/OUT [L] das passt


    GPIO 14 / Ground an 1 / 2 Eltako (wie rum scheint egal)


    Wusste nur nicht was mit A1 und A2 machen aber die bleiben einfach auf dem Eltako und fertig - dann ist ja alles klar :D


    Sonoff N out brauch ich ja wohl nicht unbedingt und von A2 (Eltako) kann ich ja eine Brücke zum Sonoff N Input machen.



    Ich war eventuell etwas verwirrt weil ich ja noch das ganze spiel mit dem Koppelrelais im Kopf hatte - das ja umgesetzt wurde aber nicht so funktioniert :D


    Beste Dank ich gebe Feedback !

    Habe die alten Taster drin richtig :) Sollten da neue rein ? (sind von Jung falls das interessiert )


    Kabellänge vom Schaltschrank zu den Tastern werden schon paar Meter sein. Sonoff und Koppelrelais sind direkt nebeneinander im Schaltschrank.


    PullUp hab ich bisher noch nicht.

    Hab es nun noch mit einem anderen sonoff aufgebaut - Bild im Anhang und die 3 Befehle auf der Konsole ausgeführt. (Savedata 1 / Switchmode 3 / Savedata 0)


    Sonoff kann aus und an machen ! An geht aber über Taster nicht - nur aus und dann machts so ein schnelles brrrt am Koppelrelais.






    Hier noch ein Auszug aus der Console


    21:32:58 MQT: stat/sonoff_licht_office_3d/RESULT = {"POWER":"ON"} (das ist anmachen per Sonoff)

    21:32:58 MQT: stat/sonoff_licht_office_3d/POWER = ON

    21:33:04 MQT: stat/sonoff_licht_office_3d/RESULT = {"POWER":"OFF"} (das aus per Taster)

    21:33:04 MQT: stat/sonoff_licht_office_3d/POWER = OFF


    Per Taster an geht nicht (kommt auch kein klack oder irgendwas in der Console wenn ich den Taster bei ausgeschaltenem Zustand drücke.