Sonoff offline

  • Hallo zusammen,

    im Netz und besonders hier sind einige super Filme zur Veranschaulichung wie Sonoff online gebracht werden kann.

    Eigentlich bin ich handwerklich und auch am PC ganz gut aufgestellt. Ich habe aber nach einen ganzen Tag Rumdoktorei keine Lust mehr und bin kurz vor dem zurücksenden.

    Ich meine aber hier eine Lösung zu bekommen, daher probier ich mein Glück.

    Hier mein vorgehen:

    1. Sonoff habe ich mit Strom (Stecker und Lampe - direkte Verbindung) versorgt. - Läßt sich am Schalter von Sonoff auch an und aus schalten. - LED blinkt.

    2. Die Ewelink App (original von der Verpackung habe ich per QR Code eingescannt) ist installiert.

    3. Nach Start der App - Hinzufügen von neuer (erster) Sonoff, halte ich 5 Sek. den Taster zum paren.

    4. Gehe jetzt in die WIFI Einstellungen und verbinde mich manuell mit der Sonoff - funktioniert noch alles.

    5. Zurück in der App verbinde ich mit meiner Fritzbox per SSID Eingabe und Passwort. - funktioniert immer noch alles.

    6. Danach kann ich den Namen der Sonoff ändern, da augenscheinlich das Paren funktioniert hat.

    7. UND AB HIER Bleibt die Sonoff im offline Modus.

    Ich habe im Netz schon gelesen, daß es an der Fritzbox Einstellung hängen kann.... FUNK Kanal 2.4 GHz 802.11 N + B + G ist eingestellt. 5 GHz habe ich schon ausprobiert mit an und auch auszuschalten.

    Den Namen meiner Fritzbox (alt - Fritz!Box 7490) habe ich gegen (HOMEHAGEN) ersetzt.

    Hier habe ich auch keine Lösung erhalten.

    Da die Sonoff aber sicherlch eine GUTE Lösung ist und sie ja bei vielen funktioniert,

    bin ich jetzt echt mal gespannt.

    Ihr seit meine letzte Hoffnung......


    Vielen Dank für Eure Hilfe


    GRUSS


    Siggi

    • Offizieller Beitrag

    Hallo Siggi,


    natürlich ist erst mal eine Ferndiagnose schwierig, allerdings versuchen wir trotzdem gern zu helfen.

    • Hast du mal versucht den Sonoff direkt nach dem verbinden zu schalten? Also keinen Namen zu ändern, sondern den so zu lassen.
    • Welchen Sonoff betrifft das Problem denn genau? Also Basic, RF oder andere?
    • Wie weit weg ist der Router von dem Sonoff mit dem Problem?
    • Wenn du den Sonoff verbunden hast und den Namen geändert hast, klemme den Sonoff mal Testweise ab und warte kurz. Danach wieder Spannung anlegen und warten. NICHT den kleinen Taster am Sonoff drücken. Auf die App achten und schauen ob sich der Sonoff nun verbindet.
    • Was für ein Sonoff ist das? Also mit schwarzer Aufschrift oder orangefarbener?

    Das sind nun erst mal ein paar Punkte um das ganze vielleicht einzugrenzen.

    Eines noch zur Ewelink App, hast du dich da auch mit Mail und Passwort angemeldet?


    Gruß
    Rainer

    CREATIONX

  • Hallo Rainer,


    ich fange mal von Deinen Fragen ganz unten an:

    Bei der Ewelink App habe ich mich mit Mail und Passwort angemeldet (und vorher natürlich registriert) .

    Ein Sonoff Basic sollte es sein (WIFI). Er ist weiss mit schwarzer Aufschrift. Ich habe mal ein Foto dabei getan.

    Deinen Ratschlag den Sonoff mal abzuklemmen (Nach Verbunden) hat leider keinen Erfolg gebracht.

    Der Router ist einen Meter entfernt :)

    Auch Dein Ratschlag den Sonoff ohne Namensänderung direkt zu schalten führt zu nichts. DIE LED am Sonoff sollte ja eigentlich nach Verbindung nicht mehr blinken und dauerhaft an sein....Blinkt leider immer....

    Ich hatte mir 3 Stück bestellt. Ich habe mal Testweise einen anderen Sonoff ausprobiert - gleiches Ergebnis.

    Liegts am Sonoff ? Ich bestelle sofort ein paar bei Dir ?!!!

    Ich beeeeeeeeeeeete weiter...


    Viele Grüße

    Siggi


    • Offizieller Beitrag

    Hallo Siggi,


    ich habe das ganze hier mal in unserer "Probierwerkstatt" getestet. Genutzt habe ich dazu auch die Fritzbox 7490.

    Genommen habe ich einen Basic wie du.

    Da er bereits eingerichtet war, habe ich den vorhandenen Basic aus der App komplett gelöscht. (Auf den Mülleimer klicken und löschen.)

    Danach dann ca. 7 Sek auf den Taster am Basic geklickt bis er gleichmäßig blinkt.

    Hier bin ich nun zur App gegangen um mit klick auf das + einen neuen Sonoff hinzuzufügen.

    Bei Auswahl des Sonoff (BILD anbei) den richtigen ausgewählt und dann die Daten sehr genau eingegeben.



    Danach verbindet sich ja der Sonoff mit dem Server und du kannst einen Namen eingeben. Das habe ich auch gemacht und diesen mal Basic genannt.. Damit war das Einrichten fertig - dachte ich!

    Denn nun kommt es, bei mir wurde plötzlich der Basic auch Offline gezeigt.

    In der App ist auch noch ein anderer Test - Sonoff installiert der funktioniert weiterhin.

    Der "neue" Basic allerdings erst mal nicht.

    Hier war die Lösung eine einfache. Die App, die bei mir unter iOS läuft einmal komplett beenden. Nicht nur zurück oder so, nein komplett beenden, vielleicht sogar das Gerät neu starten wenn es nicht anders geht :-).

    Als ich jedenfalls die App komplette beendet hatte und wieder startete läuft der Basic einwandfrei hier. ich lass diesen basic nun mal über das Wochenende online und werde versuchen diesen öfter zu schalten.


    Vielleicht hilft dir das weiter. Warum das so ist? Das kann ich an dieser Stelle noch nicht sagen. Ich werde suchen :)



    Lg

    Rainer


    P.S.: Natürlich darfst du auch gern bei uns bestellen ;-).

  • Hallo Rainer,

    ich habe den Fehler gefunden :(

    Ich schäme mich :(

    Wie so meist, der Fehler sitzt vor dem Computer.

    Mein Fehler war, daß ich beim koppeln des Sonoffs nach dem Passwort meiner Fritzbox gefragt werde.

    Hier habe ich immer mein Passwort eingegeben und nie das WLAN PASSWORT.

    Das wäre ja richtig gewesen. Komisch ist nur das das Anmelden des Sonoffs immer erfolgreich war. Aber ich frage jetzt gar nicht mehr warum....:whistling:

    So jetzt kanns losgehen. Ich werde gleich und morgen einiges verdrahten und sicherlich die nächsten Geräte bei Dir bestellen....

    Erstmal ganz vielen Dank.

    Das Wochenende ist gerettet.

    Ich freue mich schon drauf....

    Viele Grüße


    Siggi

  • Hi zusammen.


    Vllt. Könnt ihr mir helfen, ich bin solangsam am Verzweifeln... Ich habe das gleiche Gerät wie Siggi und ein ähnliches Problem... mir wird das Gerät immer als offline angezeigt nachdem es via Alexa oder App gesteuert wurde,

    Irgendwann funktioniert es dann aber wieder für 1 bis 2 Schaltungen. Der Router steht 2m neben dem Gerät.

    Muss ich im Router Vllt. Irgend welche Ports öffnen?

    Vielen Dank an die die Antworten.


    Beste Grüße

  • das Problem ist zwar nicht gelöst aber umgangen... wenn ich alle Geräte über den TP Link repeater laufen lasse funktioniert alles einwandfrei.


    Nochmal vielen Dank für die super Hilfe. Die nächsten Geräte kaufe ich bei euch.


    Beste Grüße


    Peter

  • Jetzt komme ich auch noch mit diesem leidigen Problem.

    Ich habe inzwischen 11 Sonoff und 1 Stk. 4 Ch. mit original Firmware in Betrieb..

    Installation und Einbindung verlief ohne Probleme. Nach ca. 2 Wochen hatte ich dann die ersten zwei Ausfälle. 2 der Basic Geräte werden nur noch offline in der App angezeigt. Eine kompletter Reset und Neuinstallation blieb ohne Erfolg. Daraufhin habe ich beide Geräte gegen neue ausgetauscht. Installation und Einbindung verlief wieder ohne Probleme. Das war vergangene Samstag. Seither waren alle Geräte permanent online. Bis heut, eines der beiden Geräte wieder offline angezeigt wurde. Ich schaffe es auch nicht, es wieder einzubinden. Egal in welchen Router ich gehe. Sendestärke ist jeweils vollkommen ausreichend. Der Anmeldevorgang verläuft vollkommen normal und wird auch entsprechend abgeschlossen, aber das Gerät wird weiterhin offline angezeigt. Ich weiß mir absolut keinen Rat mehr. Wieso funktioniert das Gerät eine Woche lang vollkommen ohne Probleme und dann plötzlich nicht mehr? Ohne irgendwas in den Einstellungen verändert zu haben. Ach so, vielleicht noch als Hintergrund, ich schalte damit ein Relais, welches meinem Garagentor die Betriebsspannung zum öffnen, bzw. schleißen gibt.

  • Hi Rainer

    Habe das selbe Problem wie Siggi

    Habe mehrmals gelöscht tablet ganz ausgeschaltet usw. den balkencod nimmt mein Scanner nicht,habe danach das ganze mit smartfon wiederholt und bin immer noch offlin.

    Gruß

    Uwe