Gosund SP111 - Tasmota - Steckdose offline verwenden

  • Hallo,


    ich möchte gerne meine Gosund SP111 Steckdose außerhalb meines WLAN's verwenden (kein WLAN vorhanden).


    In der Tasmota-Console habe ich per PulseTime eingestellt, dass die Steckdose nach einer bestimmten Zeit automatisch ausschaltet.


    Die Steckdose blinkt aber immer und sucht nach dem WLAN.

    Kann man das blinken deaktivieren?

    Wenn die Steckdose derzeit an ist, dann leuchtet sie blau, das soll auch so bleiben.


    Danke schon mal.

  • Die WLAN Suche läßt sich zwar nicht ausschalten aber du könntest in den Einstellungen eine Vorlage erstellen in der die LED's komplett deaktiviert sind.

    Online Compiler


    Sonoff-Basic / Sonoff-RF / Sonoff-Touch / Sonoff S20 / PowStro Basic / MagicHome / Sonoff-RF-Bridge mit diversen 433MHz RF Sender/Empfänger / Shelly_1 / ESP-WiFi-Dimmer / Gosund SP111 / ESP12E / WEMOS D1 Mini / ESP32Cam

    Sensoren: BME280/BMP280/HC-SR501/HC-SR04/ACS712/INA219/MHZ19B/DS3231

    mosquitto/bash/html/cgi auf RPI 2B+/Sprachsteuerung via IFTTT/4xGoogle-Home-Mini

  • Die WLAN-Suche stört mich nicht, das kann so bleiben.

    Die kompletten LED's möchte ich nicht deaktivieren, wenn die Steckdose an ist, soll die blaue LED leuchten, das klappt auch.

    Kann man nur die LED für die WLAN-Suche deaktivieren?

  • Die LED für die WLAN Suche würde ich auch gerne deaktivieren, weil ich mein WLAN Nachts über ausschalte und dadurch die LED (rot) blinkt. Habe schon etliche Schalterstellungen getestet. Funktioniert nicht richtig.

    Momentan habe ich folgendes Template: {"NAME":"Gosund SP111 2","GPIO":[321,0,320,0,2656,2720,0,0,2624,32,0,224,0,0],"FLAG":0,"BASE":45}.

    GPIO0 ist LED_i 2 und GPIO2 ist LED_i 1. Wenn man beide GPIO ausschaltet (none) blinkt die LED zwar nicht, allerdings habe ich auch keine Rückmeldung ob der Schalter an oder aus ist.

    Kann man dies separat deaktivieren?

    Danke im voraus für die Tipps


    Gruß TTU

  • Kann man dies separat deaktivieren?

    Hallo, wenn man die LED (welche leuchten soll) als Relay2 definiert und durch rule mit Relais1 zusammen einschaltet.

    {"NAME":"Gosund SP111 2led","GPIO":[257,0,0,0,2656,2720,0,0,2624,32,0,224,0,0],"FLAG":0,"BASE":45}


    Rule1 on Power1#state do Power2 %value% endon

    Rule1 1

  • Hallo, wenn man die LED (welche leuchten soll) als Relay2 definiert und durch rule mit Relais1 zusammen einschaltet.

    {"NAME":"Gosund SP111 2led","GPIO":[257,0,0,0,2656,2720,0,0,2624,32,0,224,0,0],"FLAG":0,"BASE":45}


    Rule1 on Power1#state do Power2 %value% endon

    Rule1 1

    Super, vielen Dank, hat wunderbar funktioniert, jetzt leuchtet die rote LED wie gewünscht. Bei WLAN aus ist diese auch aus (nix blinken).

    Will man die blaue LED leuchten lassen einfach den Eintrag von GPIO0 nach GPIO2 kopieren und bei GPIO0 none eintragen.

  • Hallo,

    leider funktioniert bei mir die Steckdose offline, ohne WLAN leider nicht korrekt.


    In der Tasmota-Console habe ich per PulseTime eingestellt, dass die Steckdose nach einer bestimmten Zeit automatisch ausschaltet.


    Offline klappt das aber leider nicht, online ist alles perfekt.

    Gibt es noch eine Einstellung die ich vornehmen kann?

  • Hi.


    Offline gibt es keine Zeitsynchronisierung, ohne Zeit keine Timerfunktion. Wusste ich zwar auch nicht aber offenbar gilt das auch für den Pulsetime.

    Ich weiß zwar nicht ob das dann auch für die Rules gilt aber ein versuch wäre es Wert.


    Den Pulsetime wieder raus nehmen.


    Pulsetime1 0


    Und die Rule aus Beitrag #6 ändern/erweitern:

    (der Delay bestimmt die Dauer zum ausschalten in Sekunden 300=5Min)

    Rule1 on Power1#State=1 do backlog Power2 1; delay 300; Power2 0 endon on Power1#State=0 do Power2 0 endon


    Wäre mal eine Rückmeldung interessant ob's geht.

    Online Compiler


    Sonoff-Basic / Sonoff-RF / Sonoff-Touch / Sonoff S20 / PowStro Basic / MagicHome / Sonoff-RF-Bridge mit diversen 433MHz RF Sender/Empfänger / Shelly_1 / ESP-WiFi-Dimmer / Gosund SP111 / ESP12E / WEMOS D1 Mini / ESP32Cam

    Sensoren: BME280/BMP280/HC-SR501/HC-SR04/ACS712/INA219/MHZ19B/DS3231

    mosquitto/bash/html/cgi auf RPI 2B+/Sprachsteuerung via IFTTT/4xGoogle-Home-Mini

    Einmal editiert, zuletzt von HoerMirAuf ()

  • Hallo,


    ich habe jetzt Pulsetime deaktiviert.


    Das Template habe ich aus Beitrag 6 übernommen.


    {"NAME":"Gosund SP111 2led","GPIO":[257,0,0,0,2656,2720,0,0,2624,32,0,224,0,0],"FLAG":0,"BASE":45}


    In der Console habe ich anschließend folgenden Befehl mit bestehender WLAN-Verbindung ausgeführt:


    Rule1 on Power1#State=1 do backlog Power2 1; delay 10; Power2 0 endon on Power1#State=0 do Power2 0 endon


    Wenn ich das richtig verstanden habe, dann sollte sich jetzt die Steckdose nach 10 Sekunden automatisch ausschalten.

    Leider klappt das nicht.

    Muss ich noch etwas anders machen?

  • Hi


    Ach ... ich hatte auch nen Schreibfehler, sorry:

    Rule1 on Power1#State=1 do backlog Power2 1; delay 10; Power1 0 endon on Power1#State=0 do Power2 0 endon


    nach dem delay wird der Power1 nicht der Power2 geschaltet. :rolleyes:

    Online Compiler


    Sonoff-Basic / Sonoff-RF / Sonoff-Touch / Sonoff S20 / PowStro Basic / MagicHome / Sonoff-RF-Bridge mit diversen 433MHz RF Sender/Empfänger / Shelly_1 / ESP-WiFi-Dimmer / Gosund SP111 / ESP12E / WEMOS D1 Mini / ESP32Cam

    Sensoren: BME280/BMP280/HC-SR501/HC-SR04/ACS712/INA219/MHZ19B/DS3231

    mosquitto/bash/html/cgi auf RPI 2B+/Sprachsteuerung via IFTTT/4xGoogle-Home-Mini

  • Nein, einfach so eingeben. Bzw. Copy & Paste. Dann wird die alte überschrieben


    Gelöscht wird die Rule mit Rule1 "

    Online Compiler


    Sonoff-Basic / Sonoff-RF / Sonoff-Touch / Sonoff S20 / PowStro Basic / MagicHome / Sonoff-RF-Bridge mit diversen 433MHz RF Sender/Empfänger / Shelly_1 / ESP-WiFi-Dimmer / Gosund SP111 / ESP12E / WEMOS D1 Mini / ESP32Cam

    Sensoren: BME280/BMP280/HC-SR501/HC-SR04/ACS712/INA219/MHZ19B/DS3231

    mosquitto/bash/html/cgi auf RPI 2B+/Sprachsteuerung via IFTTT/4xGoogle-Home-Mini

  • Ich habe die korrigierte Rule hinzugefügt:


    Rule1 on Power1#State=1 do backlog Power2 1; delay 10; Power1 0 endon on Power1#State=0 do Power2 0 endon


    Mit einer aktiven WLAN-Verbindung klappt es leider immer noch nicht.

    Noch eine Idee?

  • Du hast die Rule aber auch aktiviert?

    Rule1 1


    Mit einer aktiven WLAN-Verbindung klappt es leider immer noch nicht.

    Mit akitver WLAN Verbindung sollte das gehen. Was sagt der Log? Wenn du den Power1 schaltest?

    Online Compiler


    Sonoff-Basic / Sonoff-RF / Sonoff-Touch / Sonoff S20 / PowStro Basic / MagicHome / Sonoff-RF-Bridge mit diversen 433MHz RF Sender/Empfänger / Shelly_1 / ESP-WiFi-Dimmer / Gosund SP111 / ESP12E / WEMOS D1 Mini / ESP32Cam

    Sensoren: BME280/BMP280/HC-SR501/HC-SR04/ACS712/INA219/MHZ19B/DS3231

    mosquitto/bash/html/cgi auf RPI 2B+/Sprachsteuerung via IFTTT/4xGoogle-Home-Mini

  • So,


    hab nochmal nachgesehen. Ohne Zeit, also ohne NTP Sync (offline) arbeiten weder Timer noch Rules.

    Tasmota ist eben nicht für den Standalone Betrieb konzipiert.


    Einen Versuch gäbe es noch:

    Code
    Rule1
    on system#boot do time 1622628000 endon
    on Power1#State=1 do backlog Power2 1; delay 10; Power1 0 endon
    on Power1#State=0 do Power2 0 endon

    Der trigger system#boot geht ja auch schon ohne Zeitsync.

    mit "timer 1622628000" sollte der NTP deaktiviert und die zeit im Epoche Format auf heute 12:00 gesetzt werden.


    Das Tasmota Teil hat zwar nie ne richtige Zeit sollte aber dann mit den Rules bzw. Pulsetime arbeiten ... in der theorie.

    Online Compiler


    Sonoff-Basic / Sonoff-RF / Sonoff-Touch / Sonoff S20 / PowStro Basic / MagicHome / Sonoff-RF-Bridge mit diversen 433MHz RF Sender/Empfänger / Shelly_1 / ESP-WiFi-Dimmer / Gosund SP111 / ESP12E / WEMOS D1 Mini / ESP32Cam

    Sensoren: BME280/BMP280/HC-SR501/HC-SR04/ACS712/INA219/MHZ19B/DS3231

    mosquitto/bash/html/cgi auf RPI 2B+/Sprachsteuerung via IFTTT/4xGoogle-Home-Mini

    2 Mal editiert, zuletzt von HoerMirAuf ()

  • Rule1 1 hatte ich eben noch nicht aktiviert, danke für den Hinweis.

    Ich habe jetzt noch ein bisschen getestet.

    Mit folgender Rule funktioniert die Steckdose jetzt online und auch offline. :)


    RULE1 ON Power1#State=1 DO BACKLOG DELAY 100; POWER OFF ENDON


    In diesem Beispiel wird die Steckdose jetzt nach 10 Sekunden ausgeschaltet.


    Also 10 Sekunden = 100

    1 Minute = 600


    Ich benötige jetzt aber 40 Minuten (600 x 40 = 24000)


    Leider klappt das nicht, wenn ich die Steckdose anschalte, dann geht sie direkt wieder aus.

    999 ist noch möglich, reicht mir aber nicht.

    Hat da jemand noch eine Lösung für mich?

    Und danke schon mal.

  • Rule1 1 hatte ich eben noch nicht aktiviert, danke für den Hinweis.

    Hmmm.. dann hätte aber auch die Rule aus Post #6 nicht arbieten dürfen ... da steht übrigens auch Rule1 1:rolleyes:

    Egal...


    Bei 40 Minuten würde ich mit Ruletimer arbeiten. Der arbeitet mit Sekunden bis max. 65535 Sekunden


    RULE1 ON Power1#State=1 DO RuleTimer1 2400 ENDON ON Rules#Timer=1 DO Power2 0 ENDON

    Online Compiler


    Sonoff-Basic / Sonoff-RF / Sonoff-Touch / Sonoff S20 / PowStro Basic / MagicHome / Sonoff-RF-Bridge mit diversen 433MHz RF Sender/Empfänger / Shelly_1 / ESP-WiFi-Dimmer / Gosund SP111 / ESP12E / WEMOS D1 Mini / ESP32Cam

    Sensoren: BME280/BMP280/HC-SR501/HC-SR04/ACS712/INA219/MHZ19B/DS3231

    mosquitto/bash/html/cgi auf RPI 2B+/Sprachsteuerung via IFTTT/4xGoogle-Home-Mini