Homecube Rolladenschalter mit Tasmota fehlerhafte Belegung

  • Hallo,

    ich habe den Homecube Rolladenschalter von Amazon, diesen habe ich mit Tasmota geflasht (V8.5.0).


    Leider habe ich ein Problem auf der Weboberfläche und externer Ansteuerung. Als Template ist Generic (18) ausgewählt, was auch laut https://templates.blakadder.com/homecube.html das passende Template sein sollte.

    Auf der Weboberfläche stimmen die Knöpfe schon nicht.

    Der erste Button für Hoch ist korrekt und steuert das Relais für Rolladen hoch an.

    Der zweite Button für Runter hat keine Funktion, da der Knopf eigentlich ein Stop sein müsste.

    Der dritte Knopf beschriftet mit "toggle 3" steuert das 3. Relais für Rolladen runter an, mit jedem Drücken togglet das Relais.


    Wenn ich per Console den Befehl ShutterOpen1 sende, zieht das erste Relais an und der Rolladen fährt hoch.

    Bei dem Befehl ShutterClose1 zeigt der zweite Button auf der Weboberfläche "ON" an und es passiert nichts, identisch zu dem Knopf selbst.

    Mit "ShutterStop1" gehen unabhängig vom vorherigen Zustand die beiden ersten Relais auf "OFF".


    In dem Template einfach GPIO4 gegen GPIO15 tauschen hat leider nicht funktioniert. Habe es auch schon mit dem Befehl "Interlock 1,3" versucht, damit Relais 1 und 3 gegeneinander verriegelt sind.

    Hat jemand eine Idee wie ich das Problem lösen kann?



    Die Farben der Tasten stimmen auch nicht mehr zur Original-Firmware überein, vorher waren alle Tasten blau wenn keine Verfahrung aktiv war. Nach dem Flashen leuchten die Tasten nun grün und rot, blau habe ich leider seitdem nicht mehr gesehen. Kann man die GPIO-Belegung irgendwie simulieren, damit ich sehen kann was passiert und mir ein eigenes Template bauen kann?


    Wäre euch für eine Unterstützung sehr dankbar.

  • Mit Version tasmota 9.1.0 klappt es bei mir mit folgender Einstellung:


    Name: Jinvoo Curtain

    basiert auf: Generic (18)

    GPIO0: Led 1

    GPIO1: LedLink_i

    GPIO2: Led 2

    GPIO3: Button 2

    GPIO4: Relay 2

    GPIO5: Button 3


    GPIO12: Button 1

    GPIO13: Relay 1

    GPIO14: Led 4

    GPIO15: Relay 3

    GPIO16: Led 3

    GPIO17: ADC Input

  • Ist es möglich in der Firmware einzustellen, dass wenn man z.B Taste 1 betätigt und das Relais angezogen hat, dann drückt man eine andere Taste dass, das Relais von Taste 1 automatisch aus geht? Und kann man die Leds z.B Tagsüber ausschalten?

  • Ok danke an alle habs jetzt soweit hin bekommen. Den Shutter Mode nutze ich nicht da mir mein Motor keine Rückmeldung über die Position gibt.


    Mit den Leds bin ich noch am Testen, wenn ich Ledpower 1-3 auf null setze Leuchten die Leds blau wenn ich die auf eins setze leuchten sie rot. Kann ich die auch ganz ausschalten? Also weder rot noch blau?