• Ja, ich werd's auch noch mit dem python tool versuchen aber das hab ich derzeit nicht parat ;)

    probier mal das


    http://iot-bits.com/esp32/esp3…h-download-tool-tutorial/

    grüsse aus Heidelberg


    2x Touch, 6x S20, 24x Basic (davon 8x 4.Relais am GPIO), 2x 4ch Pro, 1x 4ch, 2x TH16, 2x 7-32V Sonoff, 4x POW, 6x DUAL, 20x IR+Bridge.,3 RF-Bridhge.2xZigbee-Bridhe mit 5 Geräte, ,2x Obi Steckdose,4x Shelly 2.5, 6x Shelly 1, diverse Wemos und ESP01, Wemos mit SML Script.

    Domoticz, HA-Bridge,, 3xAlexa, MQTT, Pilot APP zur Steuerung , 2xFeinstaunsensor via Domoticz

  • Das TestScript hat funktioniert.


    Ich habe nun das Script IP adresse und Mailadresse angepasst. Nun sehe auf der WebGui kein Bild mehr.


    ab dem Eintrag

    >m

    Bewegungs Alarm Kamera

    ......

    lässt sich das Script nicht kopieren, ist wohl zu lang. selbst entfernen von Leerzeilen half nicht weiter.

    Erst das entfernen der Kommentare lies das gesamte Script zu. Bild kommt aber nicht siehe Foto



    EDIT:

    wenn ich die IP mit Port 81 aufrufe sehe ich das Bild

    Bilder

    grüsse aus Heidelberg


    2x Touch, 6x S20, 24x Basic (davon 8x 4.Relais am GPIO), 2x 4ch Pro, 1x 4ch, 2x TH16, 2x 7-32V Sonoff, 4x POW, 6x DUAL, 20x IR+Bridge.,3 RF-Bridhge.2xZigbee-Bridhe mit 5 Geräte, ,2x Obi Steckdose,4x Shelly 2.5, 6x Shelly 1, diverse Wemos und ESP01, Wemos mit SML Script.

    Domoticz, HA-Bridge,, 3xAlexa, MQTT, Pilot APP zur Steuerung , 2xFeinstaunsensor via Domoticz

    Einmal editiert, zuletzt von mafrei ()

  • Danke ... werd ich mal testen :thumbup:


    EDIT:

    Hmm ... ist nur für WIN das Flashtool

    Online Compiler


    Sonoff-Basic / Sonoff-RF / Sonoff-Touch / Sonoff S20 / PowStro Basic / HomeMagic / Sonoff-RF-Bridge mit diversen 433MHz RF Sender/Empfänger / Shelly_1 / ESP-WiFi-Dimmer / Gosund SP111 / ESP12E

    Sensoren: BME280/BMP280/HC-SR501/HC-SR04/ACS712

    mosquitto/bash/html/cgi auf RPI 2B+/Sprachsteuerung via IFTTT/4xGoogle-Home-Mini

    2 Mal editiert, zuletzt von HoerMirAuf ()

  • mafrei


    Hast du eine micro SD Karte eingesetzt ?

    Meine bin erwartet die unbedingt. Das script wird auch auf die SD Karte gespeichert.

    Ohne Karte kann es nicht richtig funktionieren.

    In deinen Screenshot sieht man dass das Filesystem frei 0 ist.

    Also entweder gar keine Karte oder falsch formatiert. (Muss FAT32 sein)

    (oder die Pindefinition stimmt nicht?)


    HoerMirAuf


    Hat das eigentlich einen Grund warum so viele hier NICHT den Tasmota Standard für selbstkompilierte Bins, nämlich ATOM mit Platformio verwenden ?

    Da ist doch alles nötige drin einschliesslich Upload von binaries.

    Die Installation ist eigentlich ganz einfach und dauert keine 5 Minuten

    Mir erscheint das fast einfacher als der Online Compiler.

  • werde nachher die Karte noch einmal entfernen und neu formatieren.


    zu 2.

    Ich denke bei dem Online Compiler kann man halt deutlich wenige Fehler machen.

    Ich nutze VSC nachdem ATOM nicht mehr lief, brauchte ich auch als die SML Sache lief.

    I

    grüsse aus Heidelberg


    2x Touch, 6x S20, 24x Basic (davon 8x 4.Relais am GPIO), 2x 4ch Pro, 1x 4ch, 2x TH16, 2x 7-32V Sonoff, 4x POW, 6x DUAL, 20x IR+Bridge.,3 RF-Bridhge.2xZigbee-Bridhe mit 5 Geräte, ,2x Obi Steckdose,4x Shelly 2.5, 6x Shelly 1, diverse Wemos und ESP01, Wemos mit SML Script.

    Domoticz, HA-Bridge,, 3xAlexa, MQTT, Pilot APP zur Steuerung , 2xFeinstaunsensor via Domoticz

  • Hi


    @gemu2015

    Hat das eigentlich einen Grund warum so viele hier NICHT den Tasmota Standard für selbstkompilierte Bins, nämlich ATOM mit Platformio verwenden ?

    Da ist doch alles nötige drin einschliesslich Upload von binaries.

    Die Installation ist eigentlich ganz einfach und dauert keine 5 Minuten

    Mir erscheint das fast einfacher als der Online Compiler.

    Ist bei mir eine Philosophie Frage.

    Ich nutze kein Ubuntu, Debian oder wie die großen Linux Distributionen alles heißen.

    Sind mir zu mächtig was die inzwischen alles mit Installieren. Hat schon fast nen Windows Charakter. Ebenso die Upgrades/Updates knallen die die Platte voll mit Kram den Du nicht brauchst. Ich bin Freund von Minimal Distros wie Puppy. Aber das hat eben seinen Preis den manches ist eben nicht ganz so aktuelle oder bei einigen wenigen Dingen fehlen Abhängigkeiten.


    Mit Arduino hab ich noch selbst kompiliert. ATOM hatte ich auf meinem damals mehr oder weniger selbst gebastelten Puppy Linux dann nicht zum laufen bekommen bzw hatte keinen Bock das komplette System kurzfristig umzuwursteln und bin beim Online-Compiler angekommen. Inzwischen würde ATOM wohl sogar auf meiner Kiste laufen aber ich finde es sehr bequem mich nicht um aktuelle Firmwares-Source etc kümmern zu müssen. Und da ich seit es in Tasmota Templates gibt, eh keinen Source mehr modde und alles was ich brauche recht bequem über die user_config einstellen kann, hab ich mich nicht mehr weiter mit ATOM befasst. :)

    Online Compiler


    Sonoff-Basic / Sonoff-RF / Sonoff-Touch / Sonoff S20 / PowStro Basic / HomeMagic / Sonoff-RF-Bridge mit diversen 433MHz RF Sender/Empfänger / Shelly_1 / ESP-WiFi-Dimmer / Gosund SP111 / ESP12E

    Sensoren: BME280/BMP280/HC-SR501/HC-SR04/ACS712

    mosquitto/bash/html/cgi auf RPI 2B+/Sprachsteuerung via IFTTT/4xGoogle-Home-Mini

  • Nabend zusammen,


    ich wollte hier nur noch einen kleinen Hinweis loswerden, weil ein paar Kommentare zum Thema Geschwindigkeit kamen: ich habe bei mir per Hand die latest stable 8.5 kompiliert und geflasht, damit läuft das Modul super fix und reagiert ohne Verzögerungen, aus Spaß habe ich mal die Binary von hier aus dem Thread hochgeladen und damit reagiert das Modul total träge und man kann sich kaum durchklicken. Wenn ich es zurück flashe, ist es wieder normal schnell. Bevor ihr also eure Module tauscht, vielleicht mal mit einer anderen Version testen..

  • UPS, das muss ich mal Probieren, ist bei mir auch mit dem 2. Modul extrem träge.


    Hast du mit Script kompaliert ?

    grüsse aus Heidelberg


    2x Touch, 6x S20, 24x Basic (davon 8x 4.Relais am GPIO), 2x 4ch Pro, 1x 4ch, 2x TH16, 2x 7-32V Sonoff, 4x POW, 6x DUAL, 20x IR+Bridge.,3 RF-Bridhge.2xZigbee-Bridhe mit 5 Geräte, ,2x Obi Steckdose,4x Shelly 2.5, 6x Shelly 1, diverse Wemos und ESP01, Wemos mit SML Script.

    Domoticz, HA-Bridge,, 3xAlexa, MQTT, Pilot APP zur Steuerung , 2xFeinstaunsensor via Domoticz

    Einmal editiert, zuletzt von mafrei ()

  • Hier ein paar Erklärungen zu den Cams.


    Hardware:


    Es gibt relativ viele Cam Module mit schlechten Cam chips. Das ESP32 Trägerboard ist eigentlich immer OK.

    Diese schlechten Cam Module belasten den Clock Ausgang des ESP ungebührlich stark was zu starken Verzögerungen des Displays führt.

    Diese Cams vertragen keinerlei zusätzliche kapazitive Belastung am Clock pin (GPIO 0)

    Wenn man GPIO 0 ohne Probleme mit dem Finger berühren kann hat man ein "gutes" Modul.

    Man kann die CAM module auch getrennt kaufen und versuchen ein brauchbares zu erwischen.


    Hier ein youtube Video zu dem Problem:


    Software:


    Es gibt keinen Unterschied im CAM Treiber mit und ohne script. Wenn das script deaktiviert ist sollte sich die CAM identisch verhalten (wcstream 1)

    In dem script das ich oben gepostet habe ist "motion detection" aktiviert.

    Das ist eine sehr grosse Belastung für die CPU. Jede Sekunde wird ein Farbbild aufgenommen und von jpeg zu RGB dekodiert. Danach werden die Farbpixel in Schwarzweisspixel konvertiert und ein komplettes Schwarzweissbild abgespeichert. Dieses wird dann mit dem letzen Bild (von vor einer Sekunde) pixelweise verglichen und die absoluten Differenzen berechnet und aufsummiert.


    Deshalb ist diese Version deutlich langsamer als die "nur streaming Version"


    Um das zu vermeiden muss man einfach einen PIR Sensor anschliessen und dann bei aktivem Sensor zu reagieren z.B. ein Bild per email verschicken


    Der Vorteil des Software Motion Detection ist halt dass man die Schwelle besser einstellen kann.

  • Hallo zusammen

    Ich habe meine ESP32 CAM mit Tasmota geflasht funktioniert auch soweit super. Nun meine Frage wenn ich die Datei mit dem Script auffspielen möchte,

    muss ich dann alle Dateien (Boot Dateien) neu aufspielen oder reicht es wenn ich die eine bin Datei mit dem TASMOTIZER aufspiele.

    Wollte gern das Speichern auf SD Card ausprobieren.

  • muss ich dann alle Dateien (Boot Dateien) neu aufspielen oder reicht es wenn ich die eine bin Datei mit dem TASMOTIZER aufspiele.

    Nein

    Nein

    siehe Post 7 von gemu2015

    grüsse aus Heidelberg


    2x Touch, 6x S20, 24x Basic (davon 8x 4.Relais am GPIO), 2x 4ch Pro, 1x 4ch, 2x TH16, 2x 7-32V Sonoff, 4x POW, 6x DUAL, 20x IR+Bridge.,3 RF-Bridhge.2xZigbee-Bridhe mit 5 Geräte, ,2x Obi Steckdose,4x Shelly 2.5, 6x Shelly 1, diverse Wemos und ESP01, Wemos mit SML Script.

    Domoticz, HA-Bridge,, 3xAlexa, MQTT, Pilot APP zur Steuerung , 2xFeinstaunsensor via Domoticz

  • Hallo

    Vielen Dank hat super geklappt auch mit dem Script.

    Ein kleines Problem habe ich aber noch. Ohne Script konnte ich vorher GPIO 1 auf PWM stellen und an dem Pin ein Servo anschließen

    um die Camera zu drehen. Das Funktioniert jetzt nicht mehr. Kann ich diese Einstellung jetzt im Script machen, wenn ja wie stelle ich das an.

  • Hallo zusammen

    Habe das Beispiel Script installiert. Funktioniert auch soweit. Jetzt sind aber zwei Bilder da. In der Console habe ich wcstream auf 0 gesetzt, nun kommt kein Bild mehr. Setze ich in der Console wcstream auf 1, sind wieder zwei Bilder da. Kann mir da jemand weiter helfen.

  • IO12, IO13, IO16 sind frei verfügbar.


    das zu im script in >B den Pin auf Input


    >B


    spinm(12 I)


    und software motion detector auskommentieren


    ;mot=wc(6 1000)


    und in >S


    statt

    if mot>limit

    and timer==0

    then



    if pin[12]>0

    and timer==0

    then

  • Hi Leutz ...


    so ich hab nun auch mal meine ESP32Cam mit nem OV2640 geflasht.

    Allerdings mit der tasmota32-webcam.bin, da ich keine SD Karte zu Hand habe und wenn ich das richtig verstehe ist die bei gemu2015 bin unbedingt erforderlich.


    Flash, klappt, AP, das einbuchen ins WLAN. alles prima.

    Als Template hab ich das verwendet:


    Code
    {"NAME":"AITHINKER CAM","GPIO":[4992,1,1,1,1,5088,1,1,1,1,1,1,1,1,5089,5090,0,5091,5184,5152,0,5120,5024,5056,0,0,0,0,4928,1,5094,5095,5092,0,0,5093],"FLAG":0,"BASE":1}

    Weil das im Prinzip ja dem von gemu2015 entspricht nur eben ohne die SD Karte.


    Nur leider bekomme ich kein Bild... hab ich da irgendwas vergessen?


    EDIT:

    Ich sehe auch in der Konsole nichts von einer Kamera oder das eine gefunden würde. Wird das dort ausgegeben?

    Online Compiler


    Sonoff-Basic / Sonoff-RF / Sonoff-Touch / Sonoff S20 / PowStro Basic / HomeMagic / Sonoff-RF-Bridge mit diversen 433MHz RF Sender/Empfänger / Shelly_1 / ESP-WiFi-Dimmer / Gosund SP111 / ESP12E

    Sensoren: BME280/BMP280/HC-SR501/HC-SR04/ACS712

    mosquitto/bash/html/cgi auf RPI 2B+/Sprachsteuerung via IFTTT/4xGoogle-Home-Mini

    2 Mal editiert, zuletzt von HoerMirAuf ()