Tasmo Admin und die UpdateFunktion

  • Hallo zusammen,


    Tasmo Admin gefällt zunächst einmal sehr gut. Allerdings klappt es bei mir nicht. Meine Vorgehensweise:


    Tasmo Admin aufrufen-> Module-> Update

    .......dort habe ich über BROWSE meine Files ausgesucht. (Meine Firmware habe ich versuchsweise sogar in sonoff.bin umbenannt, ohne Auswirkung.)

    ->weiter

    .......es erscheint auf neuem Bildschirm im grünen Fenster Minimal und Firmware erfolgreich hochgeladen.

    .......ich suche mir mein Modul zum update aus

    .......

    Haken setzen bei 103 Flur Steckdose 192.168.231.31 58% 6.5.0.3-mod-1.45.4(sonoff) 4T 14h 30m 52s

    -> Start Update

    .......[21-05-2019 15:17:12][GLOBAL] Starte Update Prozess

    [21-05-2019 15:17:12][ID-5][SCHRITT-2][GLOBAL] Starte Schritt 2

    [21-05-2019 15:17:12][ID-5][SCHRITT-2][PRÜFEN] Prüfe Verbindung | VERSUCH => 1

    [21-05-2019 15:17:12][ID-5][SCHRITT-2][PRÜFEN] Verbindung erfolgreich! | Momentane Version => 6.5.0.3-mod-1.45.4(sonoff)

    [21-05-2019 15:17:12][ID-5][SCHRITT-2][OTAURL] Setze OTA URL für Firmware => NEW FW

    [21-05-2019 15:17:12][ID-5][SCHRITT-2][OTAURL] OTA Url => https://192.168.138.17:80/Tasm…data/firmwares/sonoff.bin

    [21-05-2019 15:17:12][ID-5][SCHRITT-1][OTAURL] OTA URL erfolgreich gesetzt für Firmware => NEW FW

    [21-05-2019 15:17:12][ID-5][SCHRITT-2][UPDATE] Starte Module update...

    [21-05-2019 15:17:13][ID-5][SCHRITT-2][UPDATE] Update gestartet

    [21-05-2019 15:17:13][ID-5][SCHRITT-2][PRÜFE UPDATE] Warte auf update | Sekunden => 60

    [21-05-2019 15:18:14][ID-5][SCHRITT-2][FERTIG] ============= Update fertig! =============


    Dann passiert hier erst mal nix mehr

    zurück auf Module -> Liste

    das ausgesuchte Modul zeigt die gleiche Firmware an wie vorher

    103 Flur Steckdose 192.168.231.31 58% 6.5.0.3-mod-1.45.4(sonoff) 2m 48s


    Außer einem Eintrag des OTA Urls (https://192.168.138.17:80/Tasm…data/firmwares/sonoff.bin) und einem Neustart passiert da in meinen Augen nichts.


    Auch wenn ich nun über den eingetragenen OTA-URL gehe wird nicht upgedatet.


    Ich weiß. In 99% sitzt das Problem vor der Tastatur. Also! Was mache ich falsch?


    Für Hilfestellungen wäre ich dankbar.

    FB 7590 & 7240, < 20 x Sonoffs Basic, Dual, 4 Ch pro, T2 (alle Tasmota), 10 x Shelly 2.5(Tasmota) als Rolladenschalter, 3 X Shelly Dimmer (OriginalFW), 8 x Shelly 1 (Tasmota), 1 x Sonoff SV (Tasmota) als Garagentorsteuerung, 5 X FS 20 Heizungssteuerung mit Zimmerthermostat u. Fensterkontakten, 5 x IP-Camera, 2 x Wemos D1 mini mit WLED, 3 x Wemos D1 mini mit Tasmota und 4fach-Relais als Gartenbewässerung, 1 x Frau ;)


    Mein Projekt: Smarte Gartenbewässerung

  • Ohhh mein Gott.. die 6.5.0.3.. damit hatte ich massiv Probleme.. wie bist du denn auf die gestoßen?


    guck mal hier

    TASMOTA v6.5.0 Release

    einige hatte gar keine Probleme.. bei mir ging fast gar nix mehr.


    möglicherweise hilft nur Kabel anschließen und erstmal den Speicher komplett überschreiben...


    Ich bin der derzeit übrigens bei der 6.4.1.9-mod-1.43.9 und die läuft auf einigen Geräten seit derzeit 91 Tagen am Stück ohne Probleme...

  • Hallo,
    du musst unter OTA Server IP und OTA Server Port die Werte für dein TasmoAdmin angeben.
    Bei mir läuft es unter 192.168.102.11 Port 5555 und das sind die Werte, die du angeben musst.;)

  • Habe zufällig diesen Thread gefunden. Und habe exakt das gleiche Problem wie der Thread Ersteller.

    Meine XAMP läuft unter localhost und Port 80. Kann auch 192.168.8.80 eintragen.

    Er macht angeblich alles aber null Effekt. Auch der OTE String im WEbinterface bei FW Update hat mit dem Pfad null Ergebnis. Den Pfad gibt es aber. Gebe ich den im Browser an, bietet er die bin zum Download an.

  • Da mittlerweile nur noch gepackte Versionen zum update genutzt werde konnen musstb du einen anderen EWeg gehen.

    Gib bei Tasmoadmin unter Befehle folgendes ein:

    1. otaurl http://ota.tasmota.com/tasmota/tasmota-DE.bin.gz

    2. upgrade 1


    Versuche dies zunächst bei einem Gerät auf der Konsole Ebene. Punkt1 musst du in der Folge nur 1x machen künftig reicht dann Punkt 2.

    Beachte aber das bei Punkt 1 das richtige steht, bei sensoren z.B dann otaurl http://ota.tasmota.com/tasmota/tasmota-sensors.bin.gz


    Damit lädt er immer die aktuelle Variante auf dein Gerät.

    Bilder

    grüsse aus Heidelberg


    2x Touch, 6x S20, 24x Basic (davon 8x 4.Relais am GPIO), 2x 4ch Pro, 1x 4ch, 2x TH16, 2x 7-32V Sonoff, 4x POW, 6x DUAL, 20x IR+Bridge.,3 RF-Bridhge.2xZigbee-Bridhe mit 5 Geräte, ,2x Obi Steckdose,4x Shelly 2.5, 6x Shelly 1, diverse Wemos und ESP01, Wemos mit SML Script.

    Domoticz, HA-Bridge,, 3xAlexa, MQTT, Pilot APP zur Steuerung , 2xFeinstaunsensor via Domoticz

  • siehe

    ....Da mittlerweile nur noch gepackte Versionen zum update genutzt werde .....

    grüsse aus Heidelberg


    2x Touch, 6x S20, 24x Basic (davon 8x 4.Relais am GPIO), 2x 4ch Pro, 1x 4ch, 2x TH16, 2x 7-32V Sonoff, 4x POW, 6x DUAL, 20x IR+Bridge.,3 RF-Bridhge.2xZigbee-Bridhe mit 5 Geräte, ,2x Obi Steckdose,4x Shelly 2.5, 6x Shelly 1, diverse Wemos und ESP01, Wemos mit SML Script.

    Domoticz, HA-Bridge,, 3xAlexa, MQTT, Pilot APP zur Steuerung , 2xFeinstaunsensor via Domoticz