Sonoff Touch mit Tasmota spielt verrückt

  • Moin,


    ich bin neu hier und habe mir jetzt einen Sonoff Touch zugelegt.

    Das Modell scheint vom Board her ein bisschen abzuweichen, was man so in google findet. Bestellt habe ich einen Touch, keinen T1. Deswegen steht Tasmota auch auf Touch.



    Über einen Arduino Nano und dem IDE habe ich nun dort Version 6.4.1.9 geflashed (ESP8285).


    Mein Vorhaben: Den Sonoff mit mqtt und Homebridge verbinden. Das habe ich soweit auch fertig.


    Nun habe ich auch Zugriff auf die Weboberfläche von Tasmota. Das Problem ist aber das der Touch sich von selbst gefühlt zufällig mal aktiviert/deaktiviert.

    Was ich nun probiert habe: mqtt ist aus und 5ghz der Fritzbox ist auch aus.


    Fasse ich den Schalter nicht an (er ist nur im WLAN), macht mal was er will. Mal kann ich ihn per Touch aktivieren, mal ist der Touch wie deaktiviert für ein paar Sekunden.

    Dabei leuchtet die kleine LED beinahe durchgehend, die TouchLED nur wenn der Zustand "ON" ist.


    Hier ein Auszug der Logs, gestartet mit Zustand "ON". Alles was ihr hier seht, habe ich nicht gemacht/ ausgelöst.

    Hat jmd. eine Idee was hier los ist?

    Ich würde mich riesig über Hilfe freuen.


    Mit freundlichen Grüßen

    Elektronenhirn

  • Was ist das für ein log? Web-Log? Serial Log? Welches Log-Niveau ist eingestellt? Auffällig ist schon einmal das häufige Verbinden mit dem WLAN. Die Flash-Angaben irritieren mich auch, hab allerdings keinen Touch. Welche wificonfig Konfiguraion hast du?

  • Das log ist die Consolenausgabe von der Weboberfläche von Tasmota, welche mir da angezeigt wird.

    Dabei habe ich unter Configuration -> Cofigure Logging Serial Log Level, Web Log Level und Syslog Log Level alle auf 4 gestellt.


    Auf meinem Touch befindet sich der ESP8285. Da ich nicht so nen serial usb-Adapter habe, habe ich meinen Arduino nano dafür genutzt um über diesen den Touch zu flashen.


    Was meinst du mit wificonfig Konfiguration? Ich habe einfach in die my_user_config.h mein Wlan-name eingetragen "FRITZ!Box Fon WLAN" und das Passwort dazu.

  • Hier für wificonfig:

    Code
    15:22:17 CMD: wificonfig
    15:22:17 SRC: WebConsole from 192.168.178.47
    15:22:17 RSL: Received Topic /wificonfig, Data Size 0, Data
    15:22:17 RSL: Group 0, Index 1, Command WIFICONFIG, Data
    15:22:17 RSL: RESULT = {"WifiConfig":"2 (WifiManager)"}

    Hier für Weblog 2:

    Code
    15:23:15 CMD: weblog 2
    15:23:15 SRC: WebConsole from 192.168.178.47
    15:23:15 RSL: Received Topic /weblog, Data Size 1, Data 2
    15:23:15 RSL: Group 0, Index 1, Command WEBLOG, Data 2
    15:23:15 RSL: RESULT = {"WebLog":2}

    Hier für Status 3

    Code
    15:23:57 CMD: status 3
    15:23:57 RSL: STATUS3 = {"StatusLOG":{"SerialLog":4,"WebLog":2,"SysLog":4,"LogHost":"","LogPort":514,"SSId":["FRITZ!Box Fon WLAN",""],"TelePeriod":300,"SetOption":["00008001","558180C0","00000000"]}}

    Hier für Status 6

    Code
    15:24:43 CMD: status 6
    15:24:43 RSL: STATUS = {"Status":{"Module":10,"FriendlyName":["Sonoff"],"Topic":"Zimmerlicht","ButtonTopic":"0","Power":0,"PowerOnState":3,"LedState":1,"SaveData":1,"SaveState":1,"SwitchTopic":"0","SwitchMode":[0,0,0,0,0,0,0,0],"ButtonRetain":0,"SwitchRetain":0,"SensorRetain":0,"PowerRetain":0}}
  • Hier für Status 6

    Das ist status und nicht status 6 oder hat der Tipp von Helfinger schon was gebracht? Zumindest solltest du die ganzen Logs (syslog, seriallog, weblog) alle auf 2 setzen. 4 ist nur für/s Debugging interessant.

  • Also wenn ich Status 6 eingebe kommt halt genau das raus. Du siehst ja oben, dass ich Status 6 eingeben habe.

    Ich wüsste nicht was ich anders machen kann.


    Ich habe nun alles auf 2 gesetzt, hilft trotzdem nichts. Auch syslog auf 0 hilft nicht.

    Hier nochmal das aktuelle log/console. Ich habe hier nicht einmal den Schalter berührt.

  • Ok, du hattest oben geschriebn, dass du MQTT ausgeschaltet hast.Das erklärt auch, warum bei status 6 nichts MQTT-Spezifisches kommt, was ich erwartet hatte. Mein Gefühl sagt mir, das ist keine gute Idee MQTT abzuschaltet. Denn auf der Tasmota-Website steht:


    Zitat


    The homebridge-mqttthing package has support for many types of devices and is quite flexible with different options especially for RGB/RGBW LED strips.

    As of 1.0.11 homebridge-mqttthing supports the following Homekit device types:

    Quelle hier


    Und noch das hier auf derselben Seite:

    Zitat

    To use Homebridge with Sonoff-Tasmota you need to have an existing MQTT broker set up (see wiki overview) and each of your Sonoff devices should have a unique topic set.

    Ich verstehe es so, dass du ein MQTT-PlugIn für Homebridge brauchst und dann müsste MQTT auf den Geräten wieder aktiviert werden. Es kann sein, dass du dann noch zusätzlich eine MQTTBroker brauchst. Kann aber auch sein, das das PlugIn als MQTTBroker arbeitet. Ich kenne mich mit der Homebridge überhaupt nicht aus.


    Bist du sicher, dass die Schaltvorgänge nicht vielleicht von der Homebridge generiert werden? Kannst du mal die Software stoppen und dann schauen, ob immer noch so viel geschaltet wird?

  • Also da homebridge nur mit mqtt kommuniziert und dies ja aktuell deaktiviert war, kann die schon mal nicht reinfunken.


    eclipse-mosquitto habe ich als Docker-Container bei mir auf dem Server im Netzwerk, auf dem gleichen Server ist auch homebridge als docker-container mit dem mqttthing plugin.

    Da mqtt aber aus war (extra zum testen, dass es daran nicht liegt), ist dies nicht das Problem.


    Ich habe auch noch eine zweite Fritzbox 7360, welche ich eben komplett zurück gesetzt habe. Diese hat keinen Internetanschluss und erstellt mir ein WLAN für ein komplett eigenes Netzwerk. Dann habe im sonoff das erste Wlan auf die frische Fritzbox gestellt und das zweite WLAN auf die alte Fritzbox/meine normale Box.


    Trotzdem hat der sonoff sich im neuen Netzwerk aktiviert/deaktiviert. Wie gesagt: Es ist ein komplett anderer Router!

    Nun bleibt ja an sich nicht viel übrig. Entweder bei der Software stimmt was nicht (was aber einen physischen Button druck nicht auslösen sollte), oder an der Hardware.

    Ein generelles Problem mit den Fritzboxen ist ja eigentlich nicht bekannt, welche dummes Zeug an den Sonoff schicken, oder?


    Hardware könnte es sein, dass an dem Touch generell etwas defekt ist (ich hatte ihn leider mit der echten Software nie im Betrieb, bzw. nur so 10 Sekunden) oder wie ich ihn gerade angeschlossen haben. Es ist halt ärgerlich, dass mein Boardlayout anscheinend relativ neu ist.


    Er hängt nach wie vor an den 3,3V die meine Arduino liefert. Außerdem liegt die Platine, wie auf den Bildern, bei mir auf nem großen Holzbrett ohne jegliche Verkleidung. Es liegt soweit nichts neben dran, außer der Arduino der den Strom gibt, an den 230V hatte ich ihn noch nicht. Auch war der restliche Teil des Touchs noch nie an der Platine angeschlossen.


    Jetzt ist die Frage wie ich weiter machen soll.

    Ich habe auch noch einen neuen Sonoff Basic mit dem neuen Layout, welcher noch auf der Originalen Software ist (zusammen gekauft mit dem Touch). Soll ich mich an den Basic wagen und mit dem mal probieren, wie der sich so macht? Davor würde ich ihn natürlich mal mit ewelink testen.

    Wegen dem neuen Layout könnt ihr hier nachlesen: https://github.com/arendst/Sonoff-Tasmota/wiki/Sonoff-Basic


    Vielen Dank für die Hilfe bis hier hin.


    Mit freundlichen Grüßen

    Elektronenhirn

  • Also da homebridge nur mit mqtt kommuniziert und dies ja aktuell deaktiviert war, kann die schon mal nicht reinfunken.

    Da wäre ich nicht so sicher...

    Ich habe auch noch einen neuen Sonoff Basic mit dem neuen Layout, welcher noch auf der Originalen Software ist (zusammen gekauft mit dem Touch). Soll ich mich an den Basic wagen und mit dem mal probieren, wie der sich so macht? Davor würde ich ihn natürlich mal mit ewelink testen.

    Das halte ich für eine sehr gute Idee. Reproduzierbares oder nicht reproduzierbares Verhalten hilft (fast) immer weiter.

  • Also langsam zweifle ich an mir selber, oder an meinem Amazon-Händler. Wobei eigentlich dort die Bewertungen gut sind.


    Ich habe nun den Basic in den Pair-Modus gebracht (3x blinken, dann 2s pause) und versucht in der ewelink-app zu koppeln. Es klappt einfach nicht. Habe nun die App schon auf einem iPhone Xr und einem Huawei P8 probiert, beide wollen nicht.


    Also entweder es liegt irgendwie am Wlan/Router oder ich habe einfach 2x Restmüll zugeschickt bekommen.

    Der Basic hängt aktuell auch an den 3,3V des Arduino.


    Ich werde mal bis zum Freitag abend ne Pause einlegen und dann beide Gerät mit 230V verbinden. Dann kann ich die aktuelle Stromversorgung ausschließen und noch zwei Nächte drüber schlafen..

    Irgendwo gibt es da glaube ich nen grundsätzliches Problem.

  • Oder es liegt an der Ewelink App die mal wieder down ist....


    Gerne genommen wird in dem Zusammenhang auch ein verbauter Repeater. Vor allem wenn die rot sind machen die manchmal so seltsame Sachen.

    Bei mir war es so das, wenn sich die LED Steuerung (Chinacloud) an den Repeater angemeldet hat und das Smartphone war auf der Box war keine Vebindung möglich.

    Seit ich den Mist rausgeworfen habe ist das nie mehr passiert.

  • Hi, bevor man an den Symptomen rumdoktert, würde ich die Ursachen eingrenzen.


    Dazu zählt eine stabile Spannungsversorgung, wie sie im normalen Betrieb vorgesehen ist.

    Bei Versorgung über den Arduino bezweifle ich das.

  • Moin,


    also basic und Touch sind jetzt beide an 230V und funktionieren auch beide soweit ohne größere Probleme.

    Der Touch macht sich NICHT mehr selbstständig.

    Das zu wenig Strom anscheinend zum Zustandswechsel führen kann, sehe ich einfach mal als eine Lektion.


    Nun noch eine kleine Sachen. Beide Geräte verlieren unregelmäßig mal die Verbindung zum Router.

    Kann das etwas mit dem Sleep-Kram zu tun haben? Die Distanz zum Router ist jetzt nicht wirklich groß.

  • Alles klar, ich gucke mal ob ich da noch was mache.


    Die Ausfälle sind eher selten, zudem mache ich auch nicht 50x am Tag das Licht an, dass ich da groß was merke. Abgesehen davon funktionieren die Sonoffs soweit zuverlässig und machen was sie sollen, in meinem Fall zusammen mit HomeKit.


    Vielen Dank für eure Hilfe!