Beiträge von HacksawZM

    Guten Morgen,


    ich hatte beim Flashen kein Passwort gesetzt. War auch alles gut bisher.

    Nun störte mich in den Einstellungen das bei Webpasswort ......... drin waren.

    Habe sie weggelöscht und auf speichern geklickt, da kam eine Logging-Maske.

    seither komme ich nicht mehr rein.


    Es bewahrheitet sich immer wieder: "never touch a running system" :(

    Danke, habe ich mir schon gedacht. Auch wenn ich nicht so der Script-Nerd bin, weiß

    ich schon bei vielen Sachen, was in so einem Script abläuft.

    Ich habe alle Scripte "durchwühlt" und nichts gefunden, was auch nur Ansatzweise eine Modifizierung

    der Zeitausgabe zulässt.


    Gruß und Frohes Fest. Peter

    Du gehst über die Weboberfläche des TOUCH in die Einstellungen und dort in MQTT konfigurieren

    Dort vergibst Du einen eindeutigen Namen unter "topic = %topic% (sonoff)" In meinem Fall ist es

    das Wohnzimmerlicht, deshalb living


    Dann kannst Du unter Openhab ein Item anlegen.


    Switch livinglamp "Stubenlampe" <switch> { mqtt=">[broker:cmnd/living/power:command:*:default], <[broker:stat/living/POWER:state:default]" }


    living ersetzen durch deinen gwählten Namen im TOUCH-Topic.


    Gruß Peter


    PS: Der Item-Befehl ist eine Zeile, wird hier im Forum umgebrochen.


    Die Laufzeit wird ja nur in Stunden angegeben. Kann man das irgendwo in dem Tasmota-Script ändern?

    Und wenn Ja, wo?

    Hätte es gerne in Sekunden, damit ich es in Openhab formatieren kann und anzeigen.

    Im Moment steht nur 107 Stunden. Will dann aus den Sekunden eine Anzeige machen

    z.B. "xx Jahr(e), xx Monate(e), xx Tage(e) xx Stunde(n), xx Minute(n), xx Sekunde(n)"


    Gruß Peter

    Auf der Startseite Rechts oben ist ein Haken:



    Hallo Norbert,


    Danke erstmal für das Video-Tutorial. :thumbup:

    Bei mir klappt es bis zu dem Punkt, wo ich die sonota.py starten will.

    Da kommt ein Fehler:

    File "E:\SonOTA\sonota.py", line 35, in <module>



    import netifaces



    ModuleNotFoundError: No module named 'netifaces'


    was mache ich falsch? :/


    Habe nochmal pip3 install --user -r requirements.txt ausgeführt, jetzt geht es

    Wäre vieleicht nicht schlecht den User-Account vom Forum mit dem Shop zu verknüpfen.

    Habe mir am 03.12.2017 ein Programmier- Flashmodul bestellt, heute

    angekommen. Danke für die nette Beigabe(Schoko Weihnachtsmann). :)


    Kleiner Tipp. Das Gehäuse ist nicht sehr passgenau und bedingt durch das

    harte Plaste schwer zu öffnen/schliessen. Eventuell weicheres Material

    zum drucken verwenden.


    Update: Sonoff-Basic neu geflasht mit modifizierter user_config.h und besseren LiPo.

    Hatte dabei in der platformio.ini --> env_default = sonoff in --> env_default = sonoff-DE

    geändert und mich gewundert, das ich auf der Konsole Werte bekam aber nicht in

    OpenHab. :( Dann habe ich mitbekommen das auch die Variablen "eingedeutscht" wurden. :D

    Geändert in OpenHab und jetzt läuft es. Die Nacht folgt der Test, wie lange hält der LiPo.


    Gruß Peter

    ...... Also mein Lippo 7500 mA ist bei einer Sleep Einstellung von 250 mS nach 3 Tagen leer. Und so ein 7500 mA Lippo ist schon ein kleiner Klotz.


    Gruß

    Norbert

    Würde ja reichen. Er muss ja jeweils nur die Nachtstunden überstehen. Habe mir jetzt mal bessere Solar-Panel bestellt und einen 3,2 Volt Solar LiFePo4 Akku 1500mAh.

    Grüß Dich,


    du meinst sicher diesen Eintrag hier: Jo der aktiviert den Energiesparmodus für die Dauer oder einer Laufzeit von 1ms bis zu 250ms.


    Gruß Norbert

    Code
    1. Sleep 1..250 //Set sleep duration from 1 to 250 mSec to enable energy saving

    Hmm, wäre ja etwas wenig wenn er maximal eine Viertelsekunde sich abschaltet.

    Spannendes Thema. Halte uns hier mal auf den laufenden!


    Gruß

    Martin

    Muss eine Lanze brechen für den Akku. :-) Die Eneloop waren schon nach 3 Stunden runter.

    Werde mir jetzt mal die user_config.h zu Brust nehmen und alles was ich nicht brauch auskommentieren.

    Einzig die Abfrage des BME280 lasse ich drin.

    Habe da gleich eine Frage zu #define APP_SLEEP die steht auf 0. Laut Erklärung kann man bis 250ms einstellen.

    Was bedeutet das? Wenn ich z.B. einen Logging Zyklus von 5Minuten habe, das der Sonoff bsw. nach senden der Daten sich in nach der angegebenen Zeit z.B. 250 ms "schlafen legt" und erst nach 5 Minuten wieder sendet usw. Wenn da 0 steht arbeitet er ständig. Ist das Richtig?

    1.Fazit:


    Der Akku 3.7V 1000mAh ist zu schwach oder taugt nichts(China-Ware). Habe ihn mit einem Steckernetzteil 5V 500mA mit dem Solar Charger auf 3.7V geladen. Gestern um 11:00Uhr habe ich die "Wetterstation" aufs Fensterbrett.
    Das Panel liefert bei diesem Wetter nur ca 3.75-3.8V Aber egal um 16:00 war der Akku runter auf 3V
    und der BME280 und Sonoff haben den Betrieb eingestellt. :-(

    Gleiches Heute in der Wohnung nach ca 5 Stunden war der Akku "breit".

    Teste jetzt mal 3 Eneloop AAA-Akkus á 1.2V 800mAh wie lange die halten.