Sonoff Pow R2 übermittelt über MQT falsch (gerundete) Werte

  • Hallo zusammen,

    ich habe einen Pow R2 mit der Tasmota Version 8.2.0.5 geflasht, MQTT konfiguriert und in FHEM engebunden. Soweit alles gut.

    Nur eine Sache passt nicht, der Power Messwert. Auf der Startseite zeigt er mir die Leistung in Watt richtig an. in der Konsole Übermittelt er aber einen falsch (gerundeten) Wert. Komischerweise kommt aber doch ab und an der richtige Wert durch.


    [Blockierte Grafik: https://www.dropbox.com/s/exyjxvnuj8p1s49/SonoffPowR2.jpg?dl=0]

    Code
    07:16:04 MQT: tele/DVES_32B770/SENSOR = {"Time":"2020-04-29T07:16:04","ENERGY":{"TotalStartTime":"2020-04-22T13:05:01","Total":0.235,"Yesterday":0.179,"Today":0.052,"Power":8,"ApparentPower":8,"ReactivePower":0,"Factor":1.00,"Voltage":234,"Current":0.034}}
    07:16:19 MQT: tele/DVES_32B770/SENSOR = {"Time":"2020-04-29T07:16:19","ENERGY":{"TotalStartTime":"2020-04-22T13:05:01","Total":0.237,"Yesterday":0.179,"Today":0.055,"Power":8,"ApparentPower":8,"ReactivePower":0,"Factor":1.00,"Voltage":234,"Current":0.034}}
    07:16:26 MQT: tele/DVES_32B770/SENSOR = {"Time":"2020-04-29T07:16:26","ENERGY":{"TotalStartTime":"2020-04-22T13:05:01","Total":0.237,"Yesterday":0.179,"Today":0.055,"Power":1,"ApparentPower":8,"ReactivePower":8,"Factor":0.13,"Voltage":234,"Current":0.034}}
    07:16:41 MQT: tele/DVES_32B770/SENSOR = {"Time":"2020-04-29T07:16:41","ENERGY":{"TotalStartTime":"2020-04-22T13:05:01","Total":0.237,"Yesterday":0.179,"Today":0.055,"Power":9,"ApparentPower":9,"ReactivePower":0,"Factor":1.00,"Voltage":234,"Current":0.037}}
    07:16:42 MQT: tele/DVES_32B770/SENSOR = {"Time":"2020-04-29T07:16:42","ENERGY":{"TotalStartTime":"2020-04-22T13:05:01","Total":0.237,"Yesterday":0.179,"Today":0.055,"Power":890,"ApparentPower":1016,"ReactivePower":490,"Factor":0.88,"Voltage":234,"Current":4.337}}

    Kann mir jemand sagen an was das liegt? Muss ich noch was einstellen?

    Vielen Dank für eure Hilfe.

    Grüße

    SImon

  • Hallo SimonF.,


    vielen Dank für dein Beitrag. Falls du Hilfe zu Produkten suchst, die du bei uns (CREATIONX) erworben hast, dann kannst du jederzeit die Hilfe-Seite auf unserer Seite aufrufen.

    Ich bin mir aber sicher, dass dir hier unsere fähigen Community-Mitglieder helfen werden ;-)


    P.S. besuche auch unseren YouTube-Kanal mit vielen hilfreichen Videos von uns ...


    Vielen Dank!

    (Dieser Beitrag wurde automatisch erstellt.)

  • Hallo,

    vielen Dank, so funktionierts. Aber dennoch ein komisches Verhalten dass er nicht die 790W meldet. PowerDelta war auf 80. von 8 auf 790 sind glaub ich schon mehr als 80%?! Ich dachte dass er hier irgendwie rundet:/

    Ich hab nun PowerDelta 200 eingegeben sodass gemeldet wird wenn ein Delta von 100 Watt entsteht. Das ist für meine Zwecke ausreichend.

    Und ich beschäftige mich erstmal mit den Tasmota Commands;)


    Grüße

    Simon