WiFi Dimmer mit einen TYWE3S

  • Hallo ,

    ich habe hier einen WiFi Dimmer mit einen TYWE3S welchen ich mit Tasmota geflasht habe.Hab dazu die -Sonoff-Tasmota-dev-6.6.0.6-DE-DimmerScript_1MB.bin – genommen.Hat auch Problemlos funktioniert.

    Mein Problem ist nun ,den Dimmer auzusprechen.

    Betätige ich die Taste am Gerät schaltet der Dimmer 100% ein oder halt aus.

    Von der Sonoff Tasmota Oberfläche funktioniert das nicht , außer ,die Kontroll LED am Gerät wird ,bei betätigen des Sliders hell oder dunkel.

    Hat jemand eine Idee ?


    Hier mal ein paar Fotos :





  • Liegt wohl daran, dass Dein Dimmer nicht der Dimmer ist, für den das bin kompiliert wurde. Dann hast wohl nichts dazu gelesen, sondern nur das bin geflasht.

    Hier ist der Thread zu dem Dimmer und im ersten Post befindet sich auch ein Link, in dem genau erklärt ist, wie man sich auch selber ein aktuelles bin kompiliert und das Script dort einfügt. Ändert aber noch nichts an der Tatsache, dass Dein Dimmer wohl ne andere GPIO Belegung hat und Du die erst mal raus finden musst.

  • Hallo Helfinger,

    ich habe mir den Beitrag nochmal durchgelesen ,komme mit der Beschreibung auch nicht weiter.

    Was ist bei mir im Ansatz falsch.

    Benötige ich das WiFi Dimmer Script wenn ja ,wo füge ich dieses ein .In der Auswahl der Einstellungen ist nichts von Script vorhanden.

    Habe noch auf 8.1.0 upgedated.

  • Steht dochn eigentlich alles dabei. Du musst Dir eine bin komplilieren bei der der Scripteditor implementiert ist und dann sollte eben dieser Editor auch über das tasmota WebIf zu erreichen sein, dort soll das Script rein kopiert werden, was aber auch exakt so dabei steht.


    Ichn habe das noch nicht gemacht, aber so wie das da steht ist es schon mal gut erklärt:

    Code
    1. To use the script, you have to compile Tasmota (v6.6.0.3 or higher) with Scripting enabled. You can use GitPod or TasmoCompiler.
    2. A precompiled binary is also here: Tasmota-v7.0.0.1-w-Scripting-2.6.x-1MB.zip
    3. Once the device is flashed with Tasmota, open Configuration -> Edit script in the web UI and paste the contents of the script in the window. Then set the script enable checkbox and push Restart. To hide “Counter1” in the WebUI you can enter WebSensor1 0 on the Tasmota Console.

    Darauf begründet sich auch meine Vermutung, dass Du da nichts gelesen hast, denn dann hätest nicht das uralte bin genommen, sondern das 7er. Wobei wenn man es selber kompiliert eh das aktuellste nimmt.


    Dann ist eben noch Dein Problem, dass Du wohl ein andere GPIO Zuordung an Deinem Dimmer hast und die musst Du erst rausfinden

  • Hallo Helfinger,

    habe nun nach dieser Beschreibung gearbeitet , mit Script einfügen und GPIO austesten.Geflasht habe ich mit der dort angegebenen Version 7.0.0.1 . Leider auch alles ohne Erfolg. Der Effekt ist der Gleiche wie in meiner 1. Beschreibung.

  • Ich habe die GPIO mit den PWM1 und mit Counter getestet. Auch ohne Erfolg. Die 7er Version habe ich genommen weil diese dort als fertig beschrieben ist. Ich habe keine Ahnung von Compilern und will einfach nur mit probieren und Tip von euch Profis mich in dieses interessante Thema annehmen . Warum soll die 7 Version nicht Funktionieren ?