Zählerwerte (Strom) in Domoticz anzeigen

  • Hallo,

    1. Wenn in Tasmota mit jedem Impuls weitergezählt wird ist doch soweit alles in Ordnung. Tasmota leitet praktisch den Impuls an Domoticz weiter.

    2. Wie viele Impulse von deinem Zähler geben 1 KWh? Bei meinem alten Zähler waren es 75, beim neuen mit S0 Anschluss sind es 1000. Da muss der Wert in Domoticz schon stimmen.

    3. Schau dir die Domoticz Einstellungen noch Mal an, es muss funktionieren.

  • Ich gebe dir ja recht, aber es ist so das er nur die Impulse hochzählt und keine Berechnung an kWh darstellt. ;(


    Ich habe dir Einstellungen schon mehrfach überprüft, es stimmt alles. Bei mir sind es auch die 1000, das sehe ich ja auch in der andren Möglichkeit mit der Script Variante hier im Forum.

    Im Moment überlege ich gerade ob die Daten mit rules an domoticz zu senden möglich ist.

    grüsse aus Heidelberg


    1x Touch, 6x S20, 24x Basic (davon 8x 2.Relais am GPIO), 2x 4ch Pro, 1x 4ch, 1x TH16, 2x 7-32V Sonoff, 4x POW, 6x DUAL, 1x PIR+Bridge,2x Obi Steckdose

    Domoticz, HA-Bridge, 2xHarmonyHub, 3xAlexa, MQTT, Homebridge-HomeKit-Siri , 2xFeinstaunsensor via Domoticz

  • Wer ist ER?

    Tasmota zählt, Domoticz rechnet in KWh um.

    Dein Gerät in Domoticz müsste als Einheit KWh anzeigen, wenn in der Gerätekonfiguration Energie ausgewählt wurde.

    Kommen gar keine Werte in Domoticz an?

    Kannst du Mal ein paar Screenshots machen?

  • Anbei mal vier relevanten Bilder gemacht , aktuellen habe ich es ausgeschaltet deswegen der rote Rahmen.

    Ist für mich auch nicht zu erklären.


    Tasmota zählt... offenbar JA

    Domoticz rechnet in KWh um. ...offenbar NEIN

  • 55,426 KWh sind doch auf dem Zähler. Woher sind dann die?

    Was wird denn angezeigt wenn du auf Protokoll gehst?

    Wenn aktiv müsste rechts nicht 0.000 sondern der Tagesverbrauch stehen.

    Diese Zahl wird einfach nur hochgezählt wenn ich es laufen lasse. Die gleiche Zahl ist auch dort zu sehen wo jetzt die 0,000 steht.

    Bei Neustart sind beide werte wieder Null und es zählt wieder hoch.


    Ich lasse es jetzt mal eine Stunden laufen und zeige dann das Bild.

    Bilder

    grüsse aus Heidelberg


    1x Touch, 6x S20, 24x Basic (davon 8x 2.Relais am GPIO), 2x 4ch Pro, 1x 4ch, 1x TH16, 2x 7-32V Sonoff, 4x POW, 6x DUAL, 1x PIR+Bridge,2x Obi Steckdose

    Domoticz, HA-Bridge, 2xHarmonyHub, 3xAlexa, MQTT, Homebridge-HomeKit-Siri , 2xFeinstaunsensor via Domoticz

  • HAllo,

    was für einen Zähler hast du eigentlich?

    Mir kommen die 1000 Impulse je KWh etwas komisch vor. Ich kenne diesen Wert nur von neueren Zählern, diese haben dann aber üblicherweise auch einen S0-Anschluss. Die alten Drehscheibenzähler laufen, nach meinem Kenntnisstand langsamer (steht auf dem Zähler).


    Auch wenn du deinen WeMo ausschältst und neu startest , sollte dort der Zählerwert nicht auf 0 gehen. Dort müsste der zuletzt gespeicherte Wert stehen bleiben (savedate on).


    In Domoticz steht rechts der Tageswert und links der komplette Verbrauch.

  • Ich habe einen elektronischen Zähler von DSG. Die Werte mit dem Script oder unter Volkszähler sind korrekt. Bei der Methode für Domoticz werden Impulse immer weiter nach oben addiert. Ich hatte das nun 2 Stunden am laufen und dazwischen Hc erstellt.

  • In Domoticz steht rechts der Tageswert und links der komplette Verbrauch.

    So hätte ich das ja gerne, aber der Wert ist immer nur am hochzählen ich lass es mal bis heute mittag so und schau dann wo der Zähler steht.

    grüsse aus Heidelberg


    1x Touch, 6x S20, 24x Basic (davon 8x 2.Relais am GPIO), 2x 4ch Pro, 1x 4ch, 1x TH16, 2x 7-32V Sonoff, 4x POW, 6x DUAL, 1x PIR+Bridge,2x Obi Steckdose

    Domoticz, HA-Bridge, 2xHarmonyHub, 3xAlexa, MQTT, Homebridge-HomeKit-Siri , 2xFeinstaunsensor via Domoticz

  • Ich denke das funktioniert schon richtig, nur deine Teilung ist nicht richtig eingegeben (Sorry für die Unterstellung;))

    Schau noch mal genau auf dem Zähler wie viele Impulse der pro KWh macht.

    Prüfe dann in Domoticz bei deinem GERÄT ob dort eine Teilung eingestellt ist >> sollte NULL sein.

    In den Domoticz-Grundeinstellungen muss dann die korrekte Teilung (vom Zähler) stehen.

  • Ich denke das funktioniert schon richtig, nur deine Teilung ist nicht richtig eingegeben (Sorry für die Unterstellung;))

    keine Problem, ich wäre ja froh wenn es funktionieren würde. Bei der Teilung habe ich auch schon mit geänderten Werten probiert, aber es ändert nichts. Er addiert nur noch oben. Anbei aktuelles Bild na ca. 3 Stunden.

    Bilder

    grüsse aus Heidelberg


    1x Touch, 6x S20, 24x Basic (davon 8x 2.Relais am GPIO), 2x 4ch Pro, 1x 4ch, 1x TH16, 2x 7-32V Sonoff, 4x POW, 6x DUAL, 1x PIR+Bridge,2x Obi Steckdose

    Domoticz, HA-Bridge, 2xHarmonyHub, 3xAlexa, MQTT, Homebridge-HomeKit-Siri , 2xFeinstaunsensor via Domoticz

  • Jetzt bin ich etwas verwirrt wenn du schreibst ...addiert nur nach oben.

    Das ist doch das was ein Zähler machen soll. Links der Gesamtverbrauch, rechts der Tagesverbrauch. Nur deine Werte sind halt etwas hoch (ich denke nicht das du so viel Strom verbrauchst). Hast du mal den tatsächlichen Zählerstand und deinen Domoticz-Stand miteinander verglichen? Gibt es da einen "Faktor"? Evebtuell in Domoticz 10 mal mehr oder so?.

  • Jetzt bin ich etwas verwirrt wenn du schreibst ...addiert nur nach oben.

    Das ist doch das was ein Zähler machen soll. Links der Gesamtverbrauch, rechts der Tagesverbrauch. Nur deine Werte sind halt etwas hoch (ich denke nicht das du so viel Strom verbrauchst). Hast du mal den tatsächlichen Zählerstand und deinen Domoticz-Stand miteinander verglichen? Gibt es da einen "Faktor"? Evebtuell in Domoticz 10 mal mehr oder so?.

    ja schon ich weiß nicht wie es es sonst formulieren sollte. Tatsache ist das mein aktuelle Verbrauch am Tag so um die 400W beträgt.

    Vielleicht interpretiere ich da was falsches und lass es jetzt mal einfach so laufen. Bisher sind die Tagesverbrauchswerte nicht nachvollziehbar.

    Mein täglicher Verbrach liegt im mittel c.a 10 kWh. Das passt es mit 400W*24 Std. sind 9,6 Kwh.

    Ich lass das jetzt bis morgen früh laufen, dann sollte eine Logik erkennbar sein.


    Ich dachte rechts oben sehe ich akt. Verbrauch in W, habe aber Kwh übersehen.

    grüsse aus Heidelberg


    1x Touch, 6x S20, 24x Basic (davon 8x 2.Relais am GPIO), 2x 4ch Pro, 1x 4ch, 1x TH16, 2x 7-32V Sonoff, 4x POW, 6x DUAL, 1x PIR+Bridge,2x Obi Steckdose

    Domoticz, HA-Bridge, 2xHarmonyHub, 3xAlexa, MQTT, Homebridge-HomeKit-Siri , 2xFeinstaunsensor via Domoticz

    Einmal editiert, zuletzt von mafrei ()

  • Hallo,

    das was du an deinem Stromzähler abgreifst und über Tasmota in Domoticz darstellst ist weiterhin nur ein Stromzähler (Wh / KWh).

    Es ist kein Leistungsmesser der dir die momentane Last in W / KW anzeigt.

    Zur Anzeige der aktuellen Verbrauchs müsstest du sowohl die genaue Spannung (Volt) als auch die Stromstärke (Ampere) haben. Wenn du diese Werte irgendwoher als Daten bekommst, dann lässt sich dies berechnen (Volt x Ampere = Watt).


    Wenn du aber einen elektronischen Zähler hast, hat der keinen S0-Anschluss?

    Dann könntest du dir den IR-Sensor sparen und den S0-Anschluss verwenden. Dann gibts auch keine "Stolperer" beim Zählen.

  • Wenn du aber einen elektronischen Zähler hast, hat der keinen S0-Anschluss?

    Nein hat er leider nicht.

    Ich dachte der liest den aktuellen Zählerstand und den aktuellen Verbrauch gemäß OBIS 1.8.0 ab. (wie z.B bei Volkszähler)

    Domoticz liest aber keinen Werte sondern sieht nur die Impulse und errechnet daraus den Wert. Deswegen kam ich bisher nicht weiter da meine Annahme falsch war.

    Zunächst mal: DANKE für deine Engelsgeduld.


    Auf Grund meiner Einsicht muss ich das jetzt 2-3 Tage austesten um für mich verwertbare Daten zu erhalten. Bin da aber recht zuversichtlich und werde es hier mitteilen.


    Anbei noch die Werte welches vom Zähler kommt.


    1. Zeile: Zähler nummer in HEX

    2. Teile: Zählerstand in Wh

    3. Zeile: akt.Verbrauch in W

    4. Zeile: Hersteller (DZG)

    Bilder

    grüsse aus Heidelberg


    1x Touch, 6x S20, 24x Basic (davon 8x 2.Relais am GPIO), 2x 4ch Pro, 1x 4ch, 1x TH16, 2x 7-32V Sonoff, 4x POW, 6x DUAL, 1x PIR+Bridge,2x Obi Steckdose

    Domoticz, HA-Bridge, 2xHarmonyHub, 3xAlexa, MQTT, Homebridge-HomeKit-Siri , 2xFeinstaunsensor via Domoticz

    3 Mal editiert, zuletzt von mafrei () aus folgendem Grund: Datei hoch

  • Die Methode klappt ist aber etwas ungenau. Auch sehe ich dadurch nicht den aktuellen Verbrauch.

    Ich kann in der Kosole meine Werte sehen.

    MQT: Zaehler/stat/STATUS10 = {"StatusSNS":{"Time":"2020-03-21T10:12:14","SML":{"Total_in":2207.69,"Power_curr":373.7}}}


    ich würde nun gerne den Wert Power_curr an Domoticz übergeben. Der Versuch mit


    on tele-Zaehler#Power_curr do publish domoticz/in {"idx":332,"svalue":"%value%"} endon


    funktioniert aber nicht. Erkennt jemand meinen Fehler ?

    grüsse aus Heidelberg


    1x Touch, 6x S20, 24x Basic (davon 8x 2.Relais am GPIO), 2x 4ch Pro, 1x 4ch, 1x TH16, 2x 7-32V Sonoff, 4x POW, 6x DUAL, 1x PIR+Bridge,2x Obi Steckdose

    Domoticz, HA-Bridge, 2xHarmonyHub, 3xAlexa, MQTT, Homebridge-HomeKit-Siri , 2xFeinstaunsensor via Domoticz

  • Es läuft nun, allerdings war mir die Impuls Zählung zu ungenau.

    Ich habe es nun mit einem Script am laufen der den aktuellen Verbrauch und den Zählerstand, wie es auch auf dem Zähler zu sein ist, in Domoticz darstellt.


    grüsse aus Heidelberg


    1x Touch, 6x S20, 24x Basic (davon 8x 2.Relais am GPIO), 2x 4ch Pro, 1x 4ch, 1x TH16, 2x 7-32V Sonoff, 4x POW, 6x DUAL, 1x PIR+Bridge,2x Obi Steckdose

    Domoticz, HA-Bridge, 2xHarmonyHub, 3xAlexa, MQTT, Homebridge-HomeKit-Siri , 2xFeinstaunsensor via Domoticz