Tasmota schaltet sich zufällig ein und aus

  • Hallo!

    Ich habe von Amazon OxaOxe Steckdosen mit Tasmota Firmware geflasht und schalte sie über Mosquitto aus OpenHAB, was alles auf einem Raspberry PI läuft.


    Das funktioniert auch sehr gut, ABER:

    Die Steckdosen gehen teilweise zufällig an und aus. Es gibt hierfür keinen Befehl von OpenHAB. Im OpenHAB-Event-Log sehe ich nur die Statusänderung, kein dem vorhergehendes command an die Steckdose (s. Attachment - Das ist zwar auf Events von einer Steckdose gefiltert, aber ich habe definitiv nicht versehentlich die commands rausgefiltert).


    In den Steckdosen sind keine Timer konfiguriert, das kann es also auch nicht sein. Ich bin ratlos - hat irgendwer eine Idee?


  • Interessanter wäre hier der log aus der Tasmota Konsole.

    Wie hast Du die Steckdose unter Tasmota konfiguriert?


    Ich hatte schon Probleme mit Sonoff's in der Unterverteilung (EMS) wenn an offenen Eingängen (keine Pull up/down) Button deklariert waren. Sowas kann sporatisch zum schalten führen.

    Tasmota 6.6.0 - Arduino-IDE - 1.8.7

    Sonoff-Basic / Sonoff-RF / Sonoff-Touch / Sonoff S20 / PowStro Basic / HomeMagic / Sonoff-RF-Bridge mit diversen 433MHz RF Sender/Empfänger / Shelly_1 / ESP-WiFi-Dimmer / Gosund SP111 / ESP12E Sensoren

    Sensoren: BME280/BMP280/HC-SR501/HC-SR04/ACS712

    mosquitto/bash/html/cgi auf RPI 2B+/Sprachsteuerung via IFTTT/3xGoogle-Home-Mini

  • Moin, bin mir nicht ganz sicher aber vlt könnte es mit deinen Werten von SwitchRetain usw. zu tun haben, das führt zu "ghost-switching".

    Hier im Video ist es perfekt beschrieben. Auch wenn es dein Problem nicht behebt ist es sehr interessant.

    VG