Shelly 1 ohne Wlan kein einschalten mit Lichtschalter möglich

  • Du musst den SW ( Shelly 1 ) bzw. S1/S2 ( Shelly 2 ) mit dem Ausgang vom mechanischen Schalter beschalten, dann sollte es funktionieren.

    Harry


    1xEcho Show, 1xEcho2, 3xEcho Dot, 1xEcho Connect; Broadlink RM Pro; Broadlink mini3;
    2xAVM FRITZ!BOX (7590/7490) mit DECT200/210-Steckdosen und DECT301-Heizkörperthermostat

  • Hallo zusammen...


    Um meinen Shelly in mein HomeMatic System zu integrieren, habe ich den Shelly1 mit ShellyHMLOX geflasht (also nicht mit Tasmota). Es funktionier prinzipiell auch alles so wie es soll, mich stört nur eine Kleinigkeit:


    Damit ich das Licht am Schalter ein und aus schalten kann, muss der Shelly mindestens einmal im Netzwerk gewesen sein. Ein schalten ist sonst auch nach mehreren Minuten nicht möglich. Ist der Shelly einmal im Netzwerk gewesen, kann ich das WLAN auch wieder abschalten und der Schalter funktioniert trotzdem noch.

    Aufgefallen ist mir das weil ich den Shelly in dem Raum eingebaut habe in dem meine Fritzbox hängt. Durch das herausnehmen der Sicherung war auch die Fritzbox aus, erst nachdem die Fritzbox vollständig hoch gefahren ist, konnte ich auch das Licht schalten.

    Da ich den Shelly zu Testzwecken nicht wieder ausbauen und zurückflashen möchte (bin froh das es jetzt läuft) meine Frage(n) an euch:


    Ist dieses Verhalten bei euch


    1. mit der original FW

    2. mit einem Tasmota geflashten Shelly

    3. falls jemand hat mit ShellyHMLOX geflashten Shelly


    reproduzierbar?


    Das Problem was ich damit habe ist das durch einen Stromausfall z.B. durch Blitzschlag und einen womöglichen dadurch verursachten Defekt an der Fritzbox es dann auch nachdem der Strom wieder da ist, es dann trotzdem im Haus dunkel bleibt.



    Für Rückmeldungen wäre ich sehr dankbar...!!!


    Liebe Grüße

    Kulkom

  • Hallo zusammen,


    wie oben von motorrad schon geschrieben, habe ich das gleiche Problem, bei meinem Shelly den ich seit einer Woche habe.

    Hallo

    bei einem Shelly ist ohne Wlan kein einschalten mit Lichtschalter möglich.

    Wie kann ich das ändern?

    Ich habe auf meinem Shelly "Sonoff-Tasmota 6.5.0" und wenn ich über einen Timer den Shelly schalten möchte und der Shelly kein Wlan hat, läuft nichts.

    Ich schalte Abends bis morgens 5:00 Uhr mein Wlan ab. Der Shelly soll nun eigentlich um 05:10 Uhr das Licht in der Küche EIN schalten, macht aber nichts. Manuell kann ich das Licht schalten und danach läuft auch das schalten über die Web Oberfläche.


    Als LOG bekomme ich von der Konsole folgendes:

    Ich könnte natürlich das Wlan schon ab 04:00 Uhr wieder einschalten, aber das ist ja eigentlich nicht im Sinne des Erfinders.

    Was läuft hier also falsch ?


    Ach ja, das AUS schalten mittels Timer funktioniert (mit Wlan ;-) )


    Schon einmal danke für eure Tips.


    Gruß

    Shelly_2019

  • 00:00:10 RSL: INFO3 = {"RestartReason":"Software/System restart"}

    Weil der rebootet hat und dann ohne Internet natürlich keine Zeit synchronisieren kann (NTP)

    Ohne aktuelle Zeit, keine richtigen Timer


    Woher der reboot wäre hier die Frage


    Was steht den in der Konsole wenn du wificonfig eingibst?

    Tasmota 6.5.0 - Arduino-IDE - 1.8.7

    Sonoff-Basic / Sonoff-RF / Sonoff-Touch / PowStro / HomeMagic / Sonoff-RF-Bridge mit diversen 433MHz RF Sender/Empfänger

    Sensoren: BME280/BMP280/HC-SR501

    mosquitto/bash/html/cgi auf RPI 2B+/Sprachsteuerung via IFTTT/2xGoogle-Home-Mini

  • GuMo.


    Und da liegt das Problem. Ohne Wlan bootet der Shelly neu und wechselt mangels WLAN immer wieder in den AP Mode "WifiManager" und aus die Maus.

    Wahrscheinlich hast du, wenn du in der Informatonen Seite schaust auch sehr sehr viele Startvorgänge.


    In der Konsole "wificonfig 5" eingeben dann steht die wificonfig auf "wait" und wartet auf das vergebene WLAN ohne in den AP Mode zu gehen ...

    Tasmota 6.5.0 - Arduino-IDE - 1.8.7

    Sonoff-Basic / Sonoff-RF / Sonoff-Touch / PowStro / HomeMagic / Sonoff-RF-Bridge mit diversen 433MHz RF Sender/Empfänger

    Sensoren: BME280/BMP280/HC-SR501

    mosquitto/bash/html/cgi auf RPI 2B+/Sprachsteuerung via IFTTT/2xGoogle-Home-Mini

    Einmal editiert, zuletzt von HoerMirAuf ()

  • Hallo HoerMirAuf,


    heute morgen war das Licht an :) somit scheinst du recht gehabt zu haben.

    Schon einmal danke dafür.


    Jetzt zeigt der Log folgendes an, ist das dann so OK ?

  • 00:00:06 RSL: INFO3 = {"RestartReason":"Software/System restart"}
    00:00:06 RSL: RESULT = {"POWER":"OFF"}
    00:00:06 RSL: POWER = OFF
    05:17:16 RSL: STATE = {"Time":"2019-04-11T05:17:16","Uptime":"0T00:00:15","Vcc":3.250,"SleepMode":"Dynamic","Sleep":50,"Load

    Eigentlich nicht. Immer noch ein reboot. Warum auch immer .... du bist sicher das wificonfig auf 5 steht?


    Hast du MQTT aktiv?

    Tasmota 6.5.0 - Arduino-IDE - 1.8.7

    Sonoff-Basic / Sonoff-RF / Sonoff-Touch / PowStro / HomeMagic / Sonoff-RF-Bridge mit diversen 433MHz RF Sender/Empfänger

    Sensoren: BME280/BMP280/HC-SR501

    mosquitto/bash/html/cgi auf RPI 2B+/Sprachsteuerung via IFTTT/2xGoogle-Home-Mini