Anschluss eines Tasters an Sonoff basic io2

  • Hallo,

    seit heute morgen sitze ich vor dem Läppi und komme einfach nicht weiter. Wenn ich einen Thread gefunden habe, der vermutlich in die Richtung gehen könnte,

    konnte ich wegen Unverständnisses nichts damit anfangen.


    Ich bin ja schon stolz auf mich, dass ich den Sonoff mit Tasmota 6.4.1 habe flashen können.

    Anschließend habe ich noch ein Kabel an den IO2 gelötet. Ein weiteres Kabel ist mit GND verbunden.

    Anschl.mit der statisch vergebenen IP Adresse den sonoff aufgerufen.

    Da ich die Basic Version in der platformio.ini schon ausgewählt habe, wird das Basic Modul schon angezeigt.

    Dann fangen meine Probleme an. Bei dem IO2 wähle ich Switch 3 aus (im Internet steht was von Switch Mode 3, denke das ist aber das gleiche).


    Solange ich die beiden Kabel (IO2 und GND) miteinanderder verbinde, leuchtet die angeschlossene Lampe. Kabel getrennt, Lampe aus.

    Dazu hatte ich schon was gelesen, finde es aber einfach nicht wieder.


    Mein Wunsch ist es, einfach eine Lampe mit WLAN, Schalter und später auch über iobroker zu schalten.


    WLAN einschalten und z.B. mit Taster wieder ausschalten.


    Ich hoffe auf euer Verständnis und noch mehr auf hilfreiche Hinweise.

  • Hallo Luettis,


    vielen Dank für dein Beitrag. Falls du Hilfe zu Produkten suchst, die du bei uns (CREATIONX) erworben hast, dann kannst du jederzeit die Hilfe-Seite auf unserer Seite aufrufen.

    Ich bin mir aber sicher, dass dir hier unsere fähigen Community-Mitglieder helfen werden ;-)


    P.S. besuche auch unseren YouTube-Kanal mit vielen hilfreichen Videos von uns ...


    Vielen Dank!



    (Dieser Beitrag wurde automatisch erstellt.)

  • Obwohl ich keine Logik darin gesehen habe, habe ich savedata1 , switchmode3 und savedata 0 in die Konsole eingetragen.


    und was soll ich sagen, es klappt in verbindung mit switch1 (09) .


    Es ist nicht zu glauben.

    Trotzdem bleibt für mich die Frage wie der Konsoleneintrag dem giop2 zugeordnet wird.


    Vielen Dank

  • Ich denke mal ich habe mich da auf die Schnelle etwas undeutlich ausgedrückt und den Link recht allgemein gehalten.

    Das Problem sollte in wenigen Augenblicken gelöst sein.



    Wenn beim zusammenklemmen von GPIO2 und GND das Relais schon schaltet passt der "Switch" der eingestellt wurde schonmal und du musst nur noch den Switchmode in der Konsole ändern.


    Du gehst auf die Konsole und gibst in der unteren Zeile den Switchmode ein.

    Je nachdem was du verwenden möchtest.


    --- Möchtest du einen Schalter verwenden ist

    SwitchMode 1 die korrekte Einstellung (und auch so schon eingestellt)

    Beim jeder Änderung an der Verbindung von GPIO2 und GND wird das Relais geschaltet.

    - Also wenn du die verbindest geht der auf "Ein".

    - Wenn du jetzt über Alexa oder die Weboberfläche ausschaltest geht er aus (obwohl noch verbunden)

    - Wenn du jetzt die Verbindung trennst geht er auf "Ein" (Statusänderung der Verbindung)


    --- Wenn du einen Taster anklemmen möchtest benötigst du

    Switchmode 3 oder 4. Die unterscheiden sich eigentlich nur darin wann der Schaltimpuls ausgelöst wird (beim drücken oder beim Loslassen)

    Hier beschrieben Commands - 02 Main



    Achte auch bitte auf das Leerzeichen.

    Switchmode3 funktioniert NICHT. Switchmode 3 ist korrekt.