Sonoff Basic Tasmota defekt ?

  • Ich habe jetzt ein paar Sonoff Basics Mit Tasmota 5.12.0 erfolgreich installiert. Nur einer macht mir zu schaffen. Der mit der IP 67 am Ende. Ich komme nicht auf die Benutzeroberfläche und er verliert auch immer die Verbindung nach kurzer Zeit. Dann reagiert er nicht mehr. Dann muss ich paar mal Licht an und aus machen und er ist wieder steuerbar per Alexa. Aber das hält nicht lange und auf die Benutzeroberfläche komme ich trotzdem nicht. Meinst ihr er ist defekt und ein Fall für die Tonne ?

    Als Firmware ist ja auf allen die 5.12.0 drauf. Meint ihr ich sollte per OTA updaten ?

  • Also ich habe die ganzen Basics ja heute alle in die Lampen verbaut. Die laufen auch alle bis auf die eine mit Alexa. Also kann man kein Firmware Update machen in der Benutzeroberfläche, weil da Firmware Update steht !? Hab ich einen Nachteil, wenn ich die Basics jetzt auf 5.12.0 lasse ? Ist der Basic, welcher immer die Verbindung verliert noch zu retten ?

  • Klar geht das OTA-Update über die Benutzeroberfläche...

    Aber kontrolliere bitte vorher wie gut der WLAN-Empfang ist.. sonst könnte es Probleme geben..


    Und wie gesagt erst auf die Version 5.14 updaten und erst dann auf die aktuelle.


    Ob die Probleme danach weg sind, wird dir niemand sicher sagen können. Teste es... schlimmer wird es sicher nicht ;) die 5.12 hat oft Probleme verursacht... mit der 6 sollte es besser gehen.


    Falls es danach noch Probleme gibt, sind wir ja auch noch da....

    FritzBox 6490, 4 Echo-Dots (2.Gen), 1 Raspi 3B, 1 Fire-TV-Stick, 3 Comet-DECT-Thermostate, 3 AVM Funktsteckdosen, 6 Sonoff S20, 3 Sonoff 4ch, 1 Sonoff Dual, 3 Sonoff Basic, 2 Amazon Dash-Buttons, 2 Aqara Wandtaster

  • Vielen Dank. Nur wie komme ich jetzt au die 5.14 ? Kann ich das machen ohne die Basics jetzt aus jeder Lampe raus zu holen und zu flashen ?

    Bei dem einen wird es schwer werden, da ich dort nicht mehr auf die Benutzeroberfläche komme. Lediglich 4x drücken und Wlan änder zum Beispiel geht aber.

  • Wenn du nicht mehr auf die Oberfläche kommst, siehts echt schlecht aus... dann wirste das Ding wohl rausholen müssen....

    Aber er schaltet???


    Ansonsten: Firmware runterladen... auf der Oberfläche auf Update gehen... Anweisungen folgen...

    FritzBox 6490, 4 Echo-Dots (2.Gen), 1 Raspi 3B, 1 Fire-TV-Stick, 3 Comet-DECT-Thermostate, 3 AVM Funktsteckdosen, 6 Sonoff S20, 3 Sonoff 4ch, 1 Sonoff Dual, 3 Sonoff Basic, 2 Amazon Dash-Buttons, 2 Aqara Wandtaster

  • Ja er schaltet, aber nach ca. 2 Minuten wird er in Alexa als Offline angezeigt und reagiert nicht mehr, erst wenn ich den Lichtschalter aus und wieder an mache.


    Firmware runder laden, meinst du die 5.14 ? Und dann von der 5.14 per OTA auf die aktuellste ? Richtig ? Wo finde ich die Firmware ?

  • genau.

    https://github.com/arendst/Sonoff-Tasmota/releases

    hier findest du die aktuelle und auch die 5.14

    erst von deiner 5.12 auf die 5.14 über OTA und dann von der 5.14 auf die 6....


    du kannst auch diese mod-Version nehmen.. die nehm ich auch...

    https://github.com/reloxx13/Sonoff-Tasmota-Modified/releases


    das andere klingt ziemlich nach einem WLAN Problem...

    FritzBox 6490, 4 Echo-Dots (2.Gen), 1 Raspi 3B, 1 Fire-TV-Stick, 3 Comet-DECT-Thermostate, 3 AVM Funktsteckdosen, 6 Sonoff S20, 3 Sonoff 4ch, 1 Sonoff Dual, 3 Sonoff Basic, 2 Amazon Dash-Buttons, 2 Aqara Wandtaster

  • Also der Sonoff, den ich als Defekt bezeichne verliert nach 30 Sekunden die Verbindung. Ich komme also nur kurz auf die Benutzeroberfläche. Habe es geschafft 5.14 drauf zu flashen, aber höher schaffe ich nicht. Was ist bei diesem nur das Problem ? Müll ?


    Die anderen habe ich fast alle gut durch das Update bekommen, nur auf 2 komme ich jetzt nicht mehr drauf. Auch lassen diese sich per Lichtschalter nicht mal mehr einschalten. Was kann ich hier nun tun ?

  • Was kann ich nun tun. Der eine ist ausgerechnet in der Lampe von der Küche. Der klappt nicht mehr. Auf den Lichtschalter folgt bei Betätigung null Reaktion. Licht geht nicht mehr an. LED leuchtet auch gar nicht mehr. Der zweite, welcher auch nichtmehr klappt nach dem Update, muss sagen das beim Updaten auch wohl unvollständig war, weil unterbrochen wurde wohl, leuchtet die LED, aber ich komme nicht mehr auf die Benutzeroberfläche. So ein Mist.

  • Was kann ich nun tun. Der eine ist ausgerechnet in der Lampe von der Küche. Der klappt nicht mehr. Auf den Lichtschalter folgt bei Betätigung null Reaktion. Licht geht nicht mehr an. LED leuchtet auch gar nicht mehr.

    Da wirst du nicht drum herum kommen das Ding auszubauen, es sei den du kommst an den Button ran.

    Evtl. bringt ein Reset was:

    Den Button am Sonoff 40 Sekunden gedrückt halten.

    Dann startet das Ding neu, ohne hinterlegte Daten und kann z.b. mit 4x schnell den Button drücken in AP-Mode versetzt werden um neu im WLAN angelernt und konfiguriert werden.

    Tut sich da bei 40 Sekunden drücken gar nix mehr ist beim Update ebenfalls was schief gegangen und dir bleibt nur flashen.


    Der zweite, welcher auch nichtmehr klappt nach dem Update, muss sagen das beim Updaten auch wohl unvollständig war, weil unterbrochen wurde wohl, leuchtet die LED, aber ich komme nicht mehr auf die Benutzeroberfläche. So ein Mist.

    Gilt daselbe wie im ersten Part.


    EDIT:

    Ich schätze wir alle hier mussten schon Sonoffs zum reseten / neu flashen wieder aus bauen. ;)

    Tasmota 6.5.0 - Arduino-IDE - 1.8.7

    Sonoff-Basic / Sonoff-RF / Sonoff-Touch / PowStro / HomeMagic / Sonoff-RF-Bridge mit diversen 433MHz RF Sender/Empfänger

    Sensoren: BME280/BMP280/HC-SR501

    mosquitto/bash/html/cgi auf RPI 2B+/Sprachsteuerung via IFTTT/2xGoogle-Home-Mini

  • Ok, habe die betroffenen Sonofs Basic neu geflasht. Klappen jetzt wieder. Der einer, welcher nicht richtig klappt, dort habe ich eine lose Lötstelle entdeckt, werde es später löten und schauen, ob es das war.

    Habe hier noch paar Sonoff S20, welche ich auch up to date bringen will. Bei 2 habe ich auch hier wieder große Probleme. Selbst nach dem Flashen bleibt es so. Bekomme einfach keine Verbindung mehr zu den Sonoffs S20. Habe diese auch ganz normal geflasht mit der 5.12 erst mal.

  • Solange du mit FTDI am PC etc. hängst,

    könntest du über ein Terminalprogramm den Bootvorgang,

    WLAN Verbindungsversuch usw. beobachten

    (wenn deine .bin serielles logging aktiviert hat).


    Da erkennt man oft, woran es liegt

    und im Terminal können auch alle Befehle eingegeben werden

    (wie sonst in der Konsole).

  • Mit einem Terminal-Programm (z.B. Termite),

    sobald der Flashvorgang abgeschlossen ist,

    startet man eine Verbindung im Terminal mit dem gleichen COM-Port.


    Beim Sonoff dabei kurz die Versorgung unterbrechen für Neustart.


    Alles was man dann im Terminal beobachten kann,

    entspricht dem sonst in der Konsole (jetzt aber ohne WLAN möglich).

  • Habe nun noch einen Sonoff S20, welcher Probleme macht. Hilft es weiter, wenn ich euch mitteile, dass er nach dem erfolgreichen Flashvorgang die grüne LED blinkt und die blaue LED konstant leuchtet.


    Edit: Ich konnte das Problem lösen und den Sonoff S20 wieder zum laufen bekommen. Habe den kompletten Flashspeicher gelöscht und danach erst die 5.12 geflasht. Danach die minimal, 5.14 und dann die modifizierte, welche hier verlinkt wurde.


    Jetzt hab ich noch ein Anliegen. Habe mir Mal vor paar Wochen 2 Sonoff 4Ch gekauft. Muss da morgen erst mal Pins drauf löten.

    Muss ich irgend etwas beim Flashen der Geräte beachten und wie sind diese in Tasmota später zu konfigurieren ?

  • Erstmal zu deinem Ersten Problem....

    dass das mit dem Flash-Speicher löschen die Lösung war, deutet darauf hin, das bei irgendeinem vorherigen Flashvorgang irgendwas schief gegangen ist, wahrscheinlich wegen einem Verbindungsabbruch...


    Das du erst mit der mod-Version wirklich problemlos bist, könnte auch auf ein MQTT Problem hindeuten.

    Ich vermute mal, das du keinen MQTT-Server zuhause hast... ältere Versionen, bei denen MQTT aktiviert war, hatte oft das Problem das sie ständig vergeblich nach ihrem Server suchen und damit sich selber blockieren...


    zu dem 4ch...

    erstmal vorweg.. es gibt den 4ch und den 4ch pro...

    beide sind unterschiedlich zu flashen...

    ich kann nur beim 4ch helfen...


    Ich habe auch nicht gelötet...

    Ich hab die Pins beim flashen einfach in die Löcher gesteckt, verkantet und festgehalten...


    Zum flashen gibts hier

    https://github.com/arendst/Son…ki/Sonoff-4CH-and-4CH-Pro

    die Anleitung.


    Beim 4ch muss man noch Button 1 drücken, während man die Kabel einstöpselt... oder so...

    also ein bishen anders, steht da aber gut beschrieben...


    Die Bedienung / Einstellung über die Weboberfläche ist genauso wie bei Basic oder S20, nur das du ebend 4 Schalter hast.

    Für eine Alexa-Verbingung musst du aber die Hue-Emulation einstellen, anstatt der WeMo-Emulation für Basic oder S20....

    FritzBox 6490, 4 Echo-Dots (2.Gen), 1 Raspi 3B, 1 Fire-TV-Stick, 3 Comet-DECT-Thermostate, 3 AVM Funktsteckdosen, 6 Sonoff S20, 3 Sonoff 4ch, 1 Sonoff Dual, 3 Sonoff Basic, 2 Amazon Dash-Buttons, 2 Aqara Wandtaster