js-controller NICHT upgraden!!!