Shelly 1 verliert WLAN Empfang

  • Hallo zusammen,


    leider verliert mein Shelly 1 in der Küche das WLAN nach zirka einem Tag, sodass dieser nicht mehr bedienbar ist.

    Ein Neustart hilft nur, wenn ich den Strom in der ganzen Küche ausschalte. Dann ist der Shelly auch wieder sofort aktiv und

    kann über die App geschaltet werden.

    Hat einer eine Idee, wie der Shelly sich selbst neu startet, wenn er offline geht oder können andere Shelly die in der Wohnung sind, als eine Art Repeater

    fungieren? Wollte jetzt deswegen nicht einen eigenen Repeater anschaffen.


    Danke für eure Ideen und Unterstützungen.

    Liebe Grüße

    Rolf

  • WLAN-Probleme sind mit Shelly orig. SW bekannt,

    es gibt eine Beta-Software zum Testen dafür:


    OTA Update über die eigene IP des Shelly 1:

    http://192.168.x.x/ota?url=http://repo.shelly.cloud/firmware/review/wifi-disconnects-again/switch1-esp8266-last.zip


    OTA Update über die eigene IP des Shelly 2:

    http://192.168.x.x/ota?url=http://repo.shelly.cloud/firmware/review/wifi-disconnects-again/switch-esp8266-last.zip


    und man sollte es mit statischer IP versuchen.


    Repeaterfunktion ist so nicht möglich.


    LG

  • Ich hatte bei einem Shelly 2 auch Probleme mit Verbindungsverlust.

    Der Shelly hatte in meiner Fritzbox von Anfang an eine fest IP, aber seit ich im Menü "spezielle Einstellungen"

    als Access-Point fest die IP der Box eingestellt habe ist alles paletti. Details: klick


    Bei meinen Shelly 1 hatte ich das Problem bisher nicht, würde dann aber analog vorgehen.

    Harry


    1xEcho Show, 1xEcho2, 3xEcho Dot, 1xEcho Connect; Broadlink RM Pro; Broadlink mini3;
    2xAVM FRITZ!BOX (7590/7490) DECT200/210-Steckdosen und DECT301-Heizkörperthermostat

    Shelly 1, 2, 2.5 und H/T

    Einmal editiert, zuletzt von Harry_1964 ()

  • Da kommt folgende Meldung:


    old_version "20190103-091629/v1.4.4@165d718b"

    ...aber das ist doch die aktuelle FW-Version (s. hier), somit kein Problem, oder?

    Harry


    1xEcho Show, 1xEcho2, 3xEcho Dot, 1xEcho Connect; Broadlink RM Pro; Broadlink mini3;
    2xAVM FRITZ!BOX (7590/7490) DECT200/210-Steckdosen und DECT301-Heizkörperthermostat

    Shelly 1, 2, 2.5 und H/T

  • Hallo Zusammen,


    Ich habe das selbe Problem wie Ihr.


    Ich habe in unserem Haus und Grundstück über 30 Shellys (davon nur 1x shelly 2 der rest shelly 1) installiert.


    Leider sind jeden Tag einige davon Offline, immer wieder unterschiedliche shellys.

    Auch shellys die nahe an der Fritzbox 7590 verbaut sind im selben Zimmer.


    Alle haben in der Shelly Weboberfläche/Einstellung eine Feste IP sogar auserhalb des DHCP Bereiches bekommen. Alle haben die neuste Firmware drauf (Aktuell v1.4.5).


    Wenn man dann die FritzBox 7590 neu startet sind alle wieder erreichbar.

    Auch nur ein Aus- und wieder Einschalten des WLANs am Taster der FritzBox reicht damit wieder für gewisse Zeit alle Online und erreichbar sind.


    Ich habe schon überlegt ob ich über die Einstellungen in der FB das WLAN zu einer bestimmten Zeit automatisch aus und wieder einschalten lassen soll.


    Nur das kann doch hierfür nicht die richtige langfristige Lösung sein.


    Ich weis nicht mehr weiter wie man das Problem nun richtig beheben könnte.


    Ich bin für jeden Tip von euch Dankbar!

  • flymike

    hast du das Problem bereits lösen können?

    habe das gleiche Problem wie du :(


    Über Rückmeldung wäre ich echt dankbar :)

  • ich bin aktuell noch dabei auszuprobieren und zu experimentieren. im moment kann ich noch nicht von einer entgültigen lösung sprechen.


    wie genau ist dein status im moment (welchen router benutzt du, wieviele shellys hast du im netzwerk, wieviel geräte insgesamt im netzwerk, wie sind deine einstellungen (feste ip pro shelly?)) usw.

  • Danke dir für die Antwort!


    Hier die Daten:

    - Speedport Smart (Telekom) steht im Keller

    - EG & OG jeweils ein Acces Point (Homeway)

    - EG sind 2x Shelly2 und 3x Shelly1 verbaut

    - OG sind 3x Shelly1 verbaut

    - Alle Shellys haben die neue Firmware drauf (1.4.5)

    - ca. 15 Geräte im Netzwerk


    Habe gestern jedem nochmals eine statische IP vergeben ausserhalb des DHCP-Bereiches. Beim Einbinden der auf Werkszustand gesetzten Shellys habe ich auf die Handy-APP verzichtet und bin gleich über den Web server rein (192.168.33.1).

    Ein Shelly1 machte noch mucken. Bedeutet, im Netzwerk konnte ich den Shelly1 sehen aber nicht drauf zugreifen. Dieser war mal erreichbar mal nicht. Habe diesen mehrmals neugestartet. Danach war die Verbindung relativ stabil. Wird sich zeigen wie lange.


    Ich vermute das hier evtl. die Firmware macken hat. Kann es mir nicht anders erklären.

    Überall habe ich vollen w-lan empfang. Auch verschiedene Kanäle (1-13) getetet.

    Aber auch hier keine Verbesserung.


    Aktuell laufen die Dinger. Auch mit Alexa keine probleme.

    Hoffe es bleibt so, da ich noch weitere Shellys im Zulauf habe.


    VG,

  • also, dann sind bei dir im augenblick nur 8 shellys im netzwerk... der rest sind dann andere geräte (smartphones, pc's, etc. ect.) also keine anderen smarthomegeräte mit dem selben ESP Chip wie die Shellys haben? ist das so richtig?

  • Leute wartet einfach ab, am Montag soll ein FW-Update kommen, welches das Problem beheben soll.

    Harry


    1xEcho Show, 1xEcho2, 3xEcho Dot, 1xEcho Connect; Broadlink RM Pro; Broadlink mini3;
    2xAVM FRITZ!BOX (7590/7490) DECT200/210-Steckdosen und DECT301-Heizkörperthermostat

    Shelly 1, 2, 2.5 und H/T

  • Leute wartet einfach ab, am Montag soll ein FW-Update kommen, welches das Problem beheben soll.

    das ist mal ne gute Nachricht.

    Danke für die Info!


    Bin echt gespannt ob dann alles Reibungslos funktioniert.

    Habe gestern meine nächste Bestellung erhalten :)


    Meine Vermutung lag auch auf der Firmware.

    Die Shellys direkt anzusteuern, also ohne in das Heimnetzwerk einzubinden, gar kein Problem.

    Reagieren super schnell. Sobald ins Heimnetz eingebunden, geht der ganze mist los (natürlich nicht bei allen :)).


    flymike :

    also, dann sind bei dir im augenblick nur 8 shellys im netzwerk... der rest sind dann andere geräte (smartphones, pc's, etc. ect.) also keine anderen smarthomegeräte mit dem selben ESP Chip wie die Shellys haben? ist das so richtig?

    genau richtig!


    Kein anderes Smarthomegerät mit dem selben ESP Chip.


    Na dann lass uns mal hoffen das die neue Firmware abhilfe schafft.

  • Hallo zusammen,


    das Update auf 1.4.6 ist jetzt doch schon heute online (falls es nicht angezeigt wird hilft ein reboot).



    Harry


    1xEcho Show, 1xEcho2, 3xEcho Dot, 1xEcho Connect; Broadlink RM Pro; Broadlink mini3;
    2xAVM FRITZ!BOX (7590/7490) DECT200/210-Steckdosen und DECT301-Heizkörperthermostat

    Shelly 1, 2, 2.5 und H/T

    2 Mal editiert, zuletzt von Harry_1964 ()

  • So jetzt ein Update.


    Auch nach der neurn Firmware hate ich das problem das im OG die Shelly schlecht liefen.

    Habe mal den Speedport durch einen AMPLIFI Router ersetzt.

    Siehe da. Alles läuft super stabil :)


    Das Problem lag am Router. Der Speedport packt anscheinend die Anzahl an Clients nicht. Waren zwar nicht viele (ca.20 Clients), aber der kam trotzdem nicht zurecht.


    Kann jedem nur empfehlen, wer auf WIFI Hausautomatisation alles aufbauen möchte sich einen richtig starken Router zu zulegen. Wenn nötig auch richtig gute Accespoints.

  • Moin liebe Mitglieder,

    habt ihr Tipps für einen anständigen Router der mit ca. 20 Shelly klar kommt?

    Bin auf dem Gebiet nicht so firm und habe absolut keine Ahnung worauf ich genau achten soll.

    Mein Speedport schmeißt die Shelly‘s nämlich regelmäßig aus dem Wifi.


    Danke schonmal im Voraus